• I


    Description

    Bessie is training for her next race by running on a path that includes hills so that she will be prepared for any terrain. She has planned a straight path and wants to run as far as she can -- but she must be back to the farm within M seconds (1 ≤ M ≤ 10,000,000).

    The entire path she has chosen is T units (1 ≤ T ≤ 100,000) in length and consists of equal-length portions that are uphill, flat, or downhill. The input data describes path segment i with a single character Si that is u, f, or d, indicating respectively uphill, flat, or downhill.

    Bessie takes U seconds (1 ≤ U ≤ 100) to run one unit of uphill path, F (1 ≤ F ≤ 100) seconds for a unit of flat path, and D (1 ≤ D ≤ 100) seconds for a unit of downhill path. Note that, when returning home, uphill paths become downhill paths and downhill paths become uphill paths.

    Find the farthest distance Bessie can get from the farm and still make it back in time.

    Input

    * Line 1: Five space-separated integers: M, T,U, F, and D * Lines 2..T+1: Line i+1 describes path segment i with a single letter: Si

    Output

    * Line 1: A single integer that is the farthest distance (number of units) that Bessie can get from the farm and make it back in time.

    Sample Input

    13 5 3 2 1
    u
    f
    u
    d
    f
    

    Sample Output

    3
    
    太水,不解释
    #include<iostream>
    using namespace std;
    char s[100000];
    int main()
    {
        int m,t,u,f,d,k=0,a;
        cin>>m>>t>>u>>f>>d;
        for(int i=0;i<t;i++)cin>>s[i];
        int i;
        for(i=0;i<t;i++){
            if(s[i]=='u'||s[i]=='d')k+=u+d;
            else k+=2*f;
            if(k>m)break;
            a=k;
        }
        cout<<i<<endl;
        //system("pause");
        return 0;
    }
  • 相关阅读:
    2020春Python程序设计_练习1
    热词分析——性能战术
    《淘宝网》质量属性
    架构师应该如何工作?
    寒假学习(十四)
    寒假学习(十三)
    灭霸冲刺(3)
    灭霸冲刺(2)
    灭霸冲刺(1)
    灭霸计划会议
  • 原文地址:https://www.cnblogs.com/farewell-farewell/p/5186744.html
Copyright © 2020-2023  润新知