• poj 2492 A Bug's Life(种类并查集)


                                                                                                                                                                                                     A Bug's Life
    Time Limit: 10000MS Memory Limit: 65536K
    Total Submissions: 52438 Accepted: 16876

    Description

    Background
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
    Problem
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

    Input

    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

    Output

    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

    Sample Input

    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4

    Sample Output

    Scenario #1:
    Suspicious bugs found!
    
    Scenario #2:
    No suspicious bugs found!

    Hint

    Huge input,scanf is recommended.
    #include<cstdio>int s[4020];//开两倍空间数组
    int find(int x){
    return x==s[x]?s[x]:s[x]=find(s[x]);//压缩路径,否则可能会超时
    }
    void Union(int x,int y){
    s[find(x)]=find(y);
    }
    int main(){
    int cnt=1,t;
    int m,n;
    scanf("%d",&t);
    while(t--){
    int flag=0;
    scanf("%d%d",&n,&m);
    for(int i=0;i<=2*n;i++)s[i]=i;
    while(m--){
    int a,b;
    scanf("%d%d",&a,&b);
    if(find(a)==find(b))flag=1;
    else{
    Union(a,b+n);//n+x表示与x性别相反的昆虫
    Union(a+n,b);
    }
    }
    if(flag)printf("Scenario #%d: Suspicious bugs found! ",cnt++);
    else printf("Scenario #%d: No suspicious bugs found! ",cnt++);
    }
    }
  • 相关阅读:
    POJ 1436 Horizontally Visible Segments (线段树+区间覆盖)
    HDU 4671 Backup Plan (构造)
    POJ 3325 Help with Intervals (线段树(难))
    HDU 4649 Professor Tian (位运算 + 按位DP)
    HDU 4662 MU Puzzle (YY+枚举)
    HDU 4638 Group (线段树 + 离线)
    深入浅出Node.js (附录A)
    JS的变量声明和函数声明提升
    JS基础:翻转数组
    JS基础:求一组数中的最大最小值,以及所在位置
  • 原文地址:https://www.cnblogs.com/fanyu1/p/12403980.html
Copyright © 2020-2023  润新知