• PTA --- 天梯赛 L1-064 估值一亿的AI核心代码


    L1-064 估值一亿的AI核心代码 (20 point(s))

    本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

    • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
    • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
    • 把原文中所有大写英文字母变成小写,除了 I
    • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
    • 把原文中所有独立的 Ime 换成 you
    • 把原文中所有的问号 ? 换成惊叹号 !
    • 在一行中输出替换后的句子作为 AI 的回答。

    输入格式:

    输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

    输出格式:

    按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

    输入样例:

    6
    Hello ?
     Good to chat   with you
    can   you speak Chinese?
    Really?
    Could you show me 5
    What Is this prime? I,don 't know

    输出样例:

    Hello ?
    AI: hello!
     Good to chat   with you
    AI: good to chat with you
    can   you speak Chinese?
    AI: I can speak chinese!
    Really?
    AI: really!
    Could you show me 5
    AI: I could show you 5
    What Is this prime? I,don 't know
    AI: what Is this prime! you,don't know

    代码:

    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
        int n;
        cin >> n;
        getchar();
        string s;
        while(n--){
            string str[1005];
            int cnt=0;
            getline(cin,s);
            cout << s << endl << "AI:";
            for(int i=0;i<s.size();++i){
                if(isalnum(s[i])){
                    if(s[i]!='I')
                        s[i]=tolower(s[i]);
                }
                else{
                    s.insert(i," ");    //对每个非字母和数字之前加空格
                    i++;
                }
                if(s[i]=='?')
                    s[i]='!';
            }
            stringstream ss(s);        //主要依靠这个函数来取消单词之前的空格
            while(ss >> s){
                str[cnt++]=s;
            }
            if(!isalnum(str[0][0]))             // 如果 第一个单词的第一个位置就是标点  那么要输出一个空格,题中要求 每个 AI 的回答前要加上 AI: 和一个空格。
                cout << " ";
            for(int i=0;i<cnt;++i){
                if(!isalnum(str[i][0])){         // 判断第一个字符是否是 标点,标点前面不要输出空格
                    cout << str[i];
                }
                else if(str[i]=="can" && str[i+1]=="you"){
                    cout << " I can";
                    i++;
                }
                else if(str[i]=="could" && str[i+1]=="you"){
                    cout << " I could";
                    i++;
                }
                else if(str[i]=="I" || str[i]=="me"){
                    cout << " you";
                }
                else
                    cout << " " << str[i];
            }
            cout << endl;
        }
    } 

    红色函数方法的详细的解释

    https://www.cnblogs.com/expedition/p/11616279.html

  • 相关阅读:
    WebService-01-使用jdk发布第一个WebService服务并调用
    Oracle触发器
    java调用存储过程、存储函数
    存储过程/存储函数
    SQL查询排名第二名的信息
    sql行转列
    SELECT列表中的标量子查询
    sql子查询在insert、update、delete中的应用
    sqlserver存储过程中,set rowcount 0是什么意思?
    固态硬盘安装系统
  • 原文地址:https://www.cnblogs.com/expedition/p/11626832.html
Copyright © 2020-2023  润新知