• uva-442 Matrix Chain Multiplication


    Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

     

    For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

    The first one takes 15000 elementary multiplications, but the second one only 3500.

     

    Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

     

    Input Specification

    Input consists of two parts: a list of matrices and a list of expressions.

    The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

     

    The second part of the input file strictly adheres to the following syntax (given in EBNF):

     

    SecondPart = Line { Line } <EOF>
    Line       = Expression <CR>
    Expression = Matrix | "(" Expression Expression ")"
    Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

     

    Output Specification

    For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

     

    Sample Input

     

    9
    A 50 10
    B 10 20
    C 20 5
    D 30 35
    E 35 15
    F 15 5
    G 5 10
    H 10 20
    I 20 25
    A
    B
    C
    (AA)
    (AB)
    (AC)
    (A(BC))
    ((AB)C)
    (((((DE)F)G)H)I)
    (D(E(F(G(HI)))))
    ((D(EF))((GH)I))

     

    Sample Output

     

    0
    0
    0
    error
    10000
    error
    3500
    15000
    40500
    47500
    15125
    题目意思:给出字符代表矩阵的定义,计算表达示中矩阵相乘的总次数;
    解题思路:定义一个stack<node>st,用node(-1,-1)代表左括号,从左到右扫描,如果是左括号则st.push(node(-1,01));如果是字母则push字母对应的矩阵;如果是右括号则把矩阵pop出来计算,一直到左括号;
    #include <iostream>
    #include<deque>
    #include<algorithm>
    #include<cstdio>
    #include<stack>
    #include<string>
    #include<vector>
    #include<map>
    using namespace std;
    
    //bool check (vector<string>&v,map<string,int>&m)
    //{
    //    for(unsigned int i=1;i<v.size();i++)
    //        if(m[v[i]]-m[v[i-1]]!=1)
    //            return false;
    //    return true;
    //}
    //int main()
    //{
    //    int cas;
    //    cin>>cas;
    //    getchar();
    //    while(cas--)
    //    {
    //        int n;
    //        cin>>n;
    //        getchar();
    //        vector<string>v;
    //        string s;
    //        map<string ,int>m;
    //        for(int i=0; i<n; i++)
    //        {
    //            getline(cin,s);
    //            v.push_back(s);
    //        }
    //        for(int i=0; i<n; i++)
    //        {
    //            getline(cin,s);
    //            m[s]=i;
    //        }
    //        for(int q=0; q<n-1;)
    //        {
    //            //if(check(v,m))break;
    //            bool flag=1;
    //            for(int i=q+1; i<n; i++)
    //            {
    //                if(m[v[q]]-m[v[i]]==1)
    //                {
    //                    cout<<v[i]<<endl;
    //                    string t=v[i];
    //                    for(int j=i; j>0; j--)
    //                        v[j]=v[j-1];
    //                    v[0]=t;
    //                    flag=0;
    //                    q=0;
    //                    break;
    //                }
    //            }
    //            if(flag)q++;
    //        }
    //        cout<<endl;
    //    }
    //    return 0;
    //}
    
    struct node
    {
        int x,y;
        node(int a=0,int b=0):x(a),y(b) {}
    };
    int main()
    {
        int n;
        cin>>n;
        char c;
        int x,y;
        node arr[200];
        for(int i=0; i<n; i++)
            cin>>c>>x>>y,arr[c]=node(x,y);
        string exp;
        while(cin>>exp)
        {
            stack<node>st;
            int sum=0;
            bool flag=0;
            for(int i=0; i<exp.size(); i++)
            {
                if(exp[i]!=')')
                {
                    if(exp[i]=='(')
                        st.push(node(-1,-1));
                    else
                        st.push(arr[exp[i]]);
                }
                else if(!st.empty())
                {
                    node matrix1=st.top();
                        st.pop();
                    while(st.top().x!=-1)
                    {
                        node matrix2=st.top();
                        st.pop();
                        if(matrix1.x!=matrix2.y)
                        {
                            flag=1;
                            cout<<"error"<<endl;
                            i=exp.size();
                            break;
                        }
                        sum+=matrix2.x*matrix2.y*matrix1.y;
                        matrix1=node(matrix2.x,matrix1.y);
                    }
                    st.pop();
                    st.push(matrix1);
                }
                else
                {
                cout<<"error"<<endl;
                flag=1;
                }
            }
            while(st.size()!=1&&!flag)
            {
                node matrix2=st.top();
                st.pop();
                node matrix1=st.top();
                st.pop();
                if(matrix1.y!=matrix2.x)
                {
                    cout<<"error"<<endl;
                    break;
                }
                st.push(node(matrix1.x,matrix2.y));
                sum+=matrix1.x*matrix1.y*matrix2.y;
            }
            if(!flag)
            cout<<sum<<endl;
        }
        return 0;
    }


  • 相关阅读:
    javascript的自定义对象
    解决trim兼容性
    AJAX
    javascript中的默认对象
    js原始数据类型
    javascript的内置对象
    空判断啊
    javascript的继承
    html如何设置P的高度为零?
    asp.net 生成静态页 自动分页
  • 原文地址:https://www.cnblogs.com/dyllove98/p/3172221.html
Copyright © 2020-2023  润新知