• HDU 1114 Piggy-Bank(动态规划、完全背包)


    Piggy-Bank

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 42725    Accepted Submission(s): 21075

     

    Problem Description

     

    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

     


    Input

     

    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

     


    Output

     

    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

     


    Sample Input

    3
    10 110
    2
    1 1
    30 50
    10 110
    2
    1 1
    50 30
    1 6
    2
    10 3
    20 4

    Sample Output

    The minimum amount of money in the piggy-bank is 60.
    The minimum amount of money in the piggy-bank is 100.
    This is impossible.

    题目大意与分析

    给出存钱罐空的时候的重量与装满的时候的重量,再给出几种货币的面值和重量,求装满的时候,面值最少是多少

    很明显的完全背包,两个重量相减是背包容量,货币的面值是价值,货币重量是代价 唯一需要注意的是必须要正好装满,装不满的都要输出 "This is impossible."

    代码

    #include<bits/stdc++.h>
    
    using namespace std;
    
    long long int x,y,v,dp[10005],t,i,n,j;
    
    int main()
    {
        cin>>t;
        while(t--)
        {
            cin>>x>>y;
            v=y-x;
            for(i=0;i<=v;i++)
            dp[i]=5000000005;
            cin>>n;
            dp[0]=0;
            for(i=1;i<=n;i++)
            {
                cin>>x>>y;
                for(j=y;j<=v;j++)
                {
                    dp[j]=min(dp[j],dp[j-y]+x);
                }
            }
            if(dp[v]!=5000000005)
            cout<<"The minimum amount of money in the piggy-bank is "<<dp[v]<<"."<<endl;
            else
            cout<<"This is impossible."<<endl;
        }
    }

     

  • 相关阅读:
    MyBatis使用总结
    RPC与RMI的区别
    Python Web-第五周-Web Services and XML(Using Python to Access Web Data)
    Python Web-第四周-Programs that Surf the Web(Using Python to Access Web Data)
    Python Web-第三周-Networks and Sockets(Using Python to Access Web Data)
    Python Web-第二周-正则表达式(Using Python to Access Web Data)
    DELL XPS 13 9350 装Win7系统(坑爹)
    手心输入法皮肤制作技巧
    请对照这二十四条逻辑谬误自行打脸(转自知乎谢熊猫专栏)
    Aspose实现Office转PDF (ASP.NET)
  • 原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/11392120.html
Copyright © 2020-2023  润新知