• HDU 2973 YAPTCHA (威尔逊定理)


    YAPTCHA

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1885    Accepted Submission(s): 971

     

    Problem Description

     

    The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.

    However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

    The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

    where [x] denotes the largest integer not greater than x.

    Input

    The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

     

    Output

    For each n given in the input output the value of Sn.

    Sample Input

    13
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    100
    1000
    10000

    Sample Output

    0
    1
    1
    2
    2
    2
    2
    3
    3
    4
    28
    207
    1609

    题目大意

    给定一个整数n,求

    题目分析

    威尔逊定理:

    当且仅当p为素数时,(p−1)!≡−1(mod p)

    所以我们可以发现,如果这个3k+7为奇数,式子就等于1,否则就等于0

    #include<bits/stdc++.h>
    
    using namespace std;
    
    const int N=5000000;
    long long a[N];
    bool prime[N];
    int i,n,j,x;
    int main()
    {
        for(i=2; i<N; i++)
        {
            if(i%2==0) prime[i]=false;
            else prime[i]=true;
        }
           for(i=3; i<=sqrt(N); i+=2)
        {   
            if(prime[i])
            for(j=i+i; j<N; j+=i)
            prime[j]=false;
        }
        for(i=1;i<=1000005;i++)
        {
            a[i]=a[i-1];
            if(prime[3*i+7])
            a[i]++;
        }
        cin>>n;
        for(i=1;i<=n;i++)
        {
            cin>>x;
            cout<<a[x]<<endl;
        }
    }

     

  • 相关阅读:
    SQL Server 父子迭代查询语句,树状查询
    金山单词2003
    算算你的女友值多少钱?(精确新版)
    腾讯QQ2006 Fianl 海峰实用版(0114)┊
    私人保险箱 5.85 免费下载
    金山快译 2007 下载个人收藏专业版
    2007最新花之神匠代码 2月份更新 (3分钟搞定)
    金山词霸2007免费下载
    写给下一个她的男友
    SAP 价格条件表PRCD_ELEMENTS
  • 原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/11374869.html
Copyright © 2020-2023  润新知