• 蓝桥杯java 基础练习 回形取数


    问题描述
      回形取数就是沿矩阵的边取数,若当前方向上无数可取或已经取过,则左转90度。一开始位于矩阵左上角,方向向下。
    输入格式
      输入第一行是两个不超过200的正整数m, n,表示矩阵的行和列。接下来m行每行n个整数,表示这个矩阵。
    输出格式
      输出只有一行,共mn个数,为输入矩阵回形取数得到的结果。数之间用一个空格分隔,行末不要有多余的空格。
    样例输入
    3 3
    1 2 3
    4 5 6
    7 8 9
    样例输出
    1 4 7 8 9 6 3 2 5
    样例输入
    3 2
    1 2
    3 4
    5 6
    样例输出
    1 3 5 6 4 2
     
    import java.util.Scanner;
    
    public class Main {
    	public static void main(String[] args) {   
            Scanner sc = new Scanner(System.in);  
            int m = sc.nextInt();  
            int n = sc.nextInt();  
            int[][] a = new int[m][n];  
            for (int i = 0; i < m; i++) {  
                for (int j = 0; j < n; j++) {  
                    a[i][j] = sc.nextInt();  
      
                }  
      
            }  
            int tot = 0, x = -1, y = 0;  
            while (tot < m * n) {  
                while (x + 1 < m && a[x + 1][y] != -1) {  
                    System.out.print(a[++x][y]+" ");  
                    a[x][y] = -1;  
                    ++tot;  
                }  
                while (y + 1 < n && a[x][y + 1] != -1) {  
                    System.out.print(a[x][++y]+" ");  
                    a[x][y] = -1;  
                    ++tot;  
                }  
                while (x - 1 >= 0 && a[x - 1][y] != -1) {  
                    System.out.print(a[--x][y]+" ");  
                    a[x][y] = -1;  
                    ++tot;  
                }  
      
                while (y - 1 >= 0 && a[x][y - 1] != -1) {  
                    System.out.print(a[x][--y]+" ");  
                    a[x][y] = -1;  
                    ++tot;  
                }  
            }  
        }  
    }
    

      

  • 相关阅读:
    spring cloud eureka 配置
    nginx 无法访问root权限的文件内容
    Linux 如何将一个文件夹的所有内容授权给某一个用户
    eclipse 注释字体不一致的问题
    java web 跨域
    tomcat的catalina.out日志文件过大
    linux 安装禅道
    修改rabbitmq Web UI 监控页面的端口
    nginx访问静态文件配置
    centos 安装单机版 redis4.0.10
  • 原文地址:https://www.cnblogs.com/duanyingkui/p/8341607.html
Copyright © 2020-2023  润新知