• HDU1002 A + B Problem II


    A + B Problem II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 265243    Accepted Submission(s): 51347


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     

     

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     

     

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     

     

    Sample Input
    2 1 2 112233445566778899 998877665544332211
     

     

    Sample Output
    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
     

     

    Author
    Ignatius.L
     

     

    Recommend
    We have carefully selected several similar problems for you:  1005 1020 1715 1040 1753 
     
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <algorithm>
    using namespace std;
    int main()
    {
        char a[1005];
        char b[1005];
        int sum[1005];
        int t,lena,lenb;
        scanf("%d",&t);
        int cout=0;
        while(t--)
        {
            cout++;
            scanf("%s",a);
            scanf("%s",b);
            lena=strlen(a);
            lenb=strlen(b);
            memset(sum,0,sizeof(sum));
            int i,j,k,l,f;
            for(i=lena-1,j=lenb-1,k=0; i>=0&&j>=0; i--,j--)
            {
                sum[k+1]=(sum[k]+a[i]-'0'+b[j]-'0')/10;
                sum[k]=(sum[k]+a[i]-'0'+b[j]-'0')%10;
                k++;
                if(i==0&&j!=0)
                {
                    for(l=j-1; l>=0; l--)
                    {
                        sum[k+1]=(sum[k]+b[l]-'0')/10;
                        sum[k]=(sum[k]+b[l]-'0')%10;
                        k++;
                    }
                }
                else if(i!=0&&j==0)
                {
                    for(l=i-1; l>=0; l--)
                    {
                        sum[k+1]=(sum[k]+a[l]-'0')/10;
                        sum[k]=(sum[k]+a[l]-'0')%10;
    
                        k++;
                    }
                }
            }
            if(sum[k]!=0)//必须放在循环外面
    k
    ++; printf("Case %d: ",cout); printf("%s + %s = ",a,b); for(f=k-1; f>=0; f--) { { printf("%d",sum[f]); } } printf(" "); if(t!=0) printf(" "); } }
  • 相关阅读:
    面试准备专题——JVM,类编译,类加载,内存错误
    面试准备-基础知识总结
    J2EE异常问题总结
    Java工具类使用注意事项
    高性能大型网站性能优化基础
    Spring Boot 2 (三):Spring Boot 开源软件都有哪些?
    Spring Boot 2(一):【重磅】Spring Boot 2.0权威发布
    Spring Boot 2 (二):Spring Boot 2 尝鲜-动态 Banner
    MFC对话框使用CPrintDialog实现打印,指定打印机、后台打印
    stm32实现iap远程固件更新
  • 原文地址:https://www.cnblogs.com/dshn/p/4760658.html
Copyright © 2020-2023  润新知