• 1126 Eulerian Path (25 分)


    In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

    Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

    Output Specification:

    For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

    Sample Input 1:

    7 12
    5 7
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    7 6
    6 3
    4 5
    6 4
    5 6
    
     

    Sample Output 1:

    2 4 4 4 4 4 2
    Eulerian
    
     

    Sample Input 2:

    6 10
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    6 3
    4 5
    6 4
    5 6
    
     

    Sample Output 2:

    2 4 4 4 3 3
    Semi-Eulerian
    
     

    Sample Input 3:

    5 8
    1 2
    2 5
    5 4
    4 1
    1 3
    3 2
    3 4
    5 3
    
     

    Sample Output 3:

    3 3 4 3 3
    Non-Eulerian



    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    #define inf 0x3fffffff
    int n,m;
    int G[maxn][maxn];
    bool vis[maxn];
    void dfs(int inx){
        vis[inx]=true;
        for(int i=1;i<=n;i++){
            if(vis[i]==false&&G[i][inx]!=inf){
                dfs(i);
            }
        }
    }
    
    int main(){
        scanf("%d %d",&n,&m);
        fill(G[0],G[0]+maxn*maxn,inf);
        fill(vis,vis+maxn,false);
        for(int i=0;i<m;i++){
            int a,b;
            scanf("%d %d",&a,&b);
            G[a][b]=G[b][a]=0;
        }
        int cnt=0;
        int dnum=0;
        vector<int> v;
        for(int i=1;i<=n;i++){
            if(vis[i]==false){
                dfs(i);
                dnum++;
            }
            cnt=0;
            for(int j=1;j<=n;j++){
                if(i!=j&&G[i][j]!=inf){
                    cnt++;
                }
            }
            v.push_back(cnt);
        }
        int count=0;
        for(auto it=v.begin();it!=v.end();it++){
            printf("%d",*it);
            if(it!=v.end()-1){
                printf(" ");
            }
            if(*it%2!=0){
                count++;
            }
        }
        printf("\n");
        if(dnum>1){
            printf("Non-Eulerian\n");
            return 0;
        }
        if(count==0){
            printf("Eulerian\n");
        }
        else if(count==2){
            printf("Semi-Eulerian\n");
        }
        else{
            printf("Non-Eulerian\n");
        }
        return 0;
    }
  • 相关阅读:
    10.26 饮食
    10.25 饮食
    10.24饮食
    关于 wpf 的ICommand 的 CanExecute CanExecuteChanged func action的认识
    2018 10 23
    [Java]先有Class还是先有Object?
    [Java]如何制作一个WordCount-Plus的Plugin
    [java] 软工实践WordCount-Plus
    [java]基本数据类型
    [java]第一个程序
  • 原文地址:https://www.cnblogs.com/dreamzj/p/15914299.html
Copyright © 2020-2023  润新知