• 1147 Heaps (30 分)


    In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

    Your job is to tell if a given complete binary tree is a heap.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

    Output Specification:

    For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

    Sample Input:

    3 8
    98 72 86 60 65 12 23 50
    8 38 25 58 52 82 70 60
    10 28 15 12 34 9 8 56
    
     

    Sample Output:

    Max Heap
    50 60 65 72 12 23 86 98
    Min Heap
    60 58 52 38 82 70 25 8
    Not Heap
    56 12 34 28 9 8 15 10



    AC代码:
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10010;
    #define inf 0x3fffffff
    int heap[maxn];
    int n,m,judge;
    bool minH(){
        for(int i=1;i<=m;i++){
            if(i*2>m){
                break;
            }
            if(heap[i*2]<heap[i]){
                return false;
            }
            if(i*2+1>m){
                break;
            }
            if(heap[i*2+1]<heap[i]){
                return false;
            }
        }
        return true;
    }
    bool maxH(){
        for(int i=1;i<=m;i++){
            if(i*2>m){
                break;
            }
            if(heap[i*2]>heap[i]){
                return false;
            }
            if(i*2+1>m){
                break;
            }
            if(heap[i*2+1]>heap[i]){
                return false;
            }
        }
        return true;
    }
    void post_order(int v){
        if(v>m){
            return;
        }
        if(v*2<=m){
            post_order(v*2);
        }
        if(v*2+1<=m){
            post_order(v*2+1);
        }
        if(judge==1){
              printf("%d\n",heap[v]);
        }
        else{
            judge--;
            printf("%d ",heap[v]);
        }
        
    }
    int main(){
        scanf("%d %d",&n,&m);
        for(int i=0;i<n;i++){
            fill(heap,heap+maxn,0);
            for(int j=1;j<=m;j++){
                scanf("%d",&heap[j]);
            }
            if(minH()){
                printf("Min Heap\n");
            }
            else if(maxH()){
                printf("Max Heap\n");
            }
            else{
                printf("Not Heap\n");
            }
            judge=m;
            post_order(1);
        }
        return 0;
    }
     
  • 相关阅读:
    【问题】解决python3不支持mysqldb
    《Craking the Coding interview》python实现---02
    《Craking the Coding interview》python实现---01
    python标准库--functools.partial
    Multimodal Machine LearningA Survey and Taxonomy
    概率热图的绘制--gradcam
    Pytorch 技巧总结(持续更新)
    linux教训
    Destruction and Construction Learning for Fine-grained Image Recognition----论文
    Ubuntu16.04+3090+cuda11.0+cudnnV8+pytorch-nightly
  • 原文地址:https://www.cnblogs.com/dreamzj/p/15902891.html
Copyright © 2020-2023  润新知