• 1034 Head of a Gang (30 分)


    One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

    Name1 Name2 Time
     

    where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

    Output Specification:

    For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

    Sample Input 1:

    8 59
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
     

    Sample Output 1:

    2
    AAA 3
    GGG 3
     

    Sample Input 2:

    8 70
    AAA BBB 10
    BBB AAA 20
    AAA CCC 40
    DDD EEE 5
    EEE DDD 70
    FFF GGG 30
    GGG HHH 20
    HHH FFF 10
     

    Sample Output 2:

    0

    有问题代码:
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1111;
    int G[maxn][maxn];
    int weight[maxn];
    map<string,int> stoInt;
    map<int,string> itoSt;
    map<string,int> ans;
    bool vis[maxn];
    int mm,a1,b1;
    int n,k;
    void dfs(int u,int &head,int &numMember,int &totalweight){
        vis[u]=true;
        numMember++;
        if(weight[u]>weight[head]){
            head=u;
        }
        for(int v=1;v<=mm;v++){
            if(G[u][v]>0){
                totalweight+=G[u][v];
                G[u][v]=G[v][u]=0;
                if(vis[v]==false){
                    dfs(v,head,numMember,totalweight);
                }
            }
        }
    }
    int main(){
        fill(G[0],G[0]+maxn*maxn,0);
        fill(vis,vis+maxn,false);
        cin>>n>>k;
        string a,b;
        int c;
        for(int i=1;i<=n;i++){
            cin>>a>>b>>c;
            a1=a[0]-'A'+1;
            stoInt[a]=a1;
            itoSt[a1]=a;
            b1=b[0]-'A'+1;
            stoInt[b]=b1;
            itoSt[b1]=b;
            G[a1][b1]+=c;
            G[b1][a1]+=c;
            weight[a1]+=c;
            weight[b1]+=c;
        }
        mm=max(a1,b1);
        for(int i=1;i<=mm;i++){
            if(vis[i]==false){
                int head=i,numMember=0,totalweight=0;
                dfs(i,head,numMember,totalweight);
                if(numMember>2&&totalweight>k){
                    ans[itoSt[head]]=numMember;
                }
            }
        }
        cout<<ans.size()<<endl;
        for(map<string,int>::iterator it=ans.begin();it!=ans.end();it++){
            cout<<it->first<<" "<<it->second<<endl;
        }
        return 0;
    }

    暂时找不到错在哪

  • 相关阅读:

    梯度下降法
    维特比算法
    分治法
    动态规划
    hadoop学习视频
    Java深拷贝浅拷贝
    Android NDK r8 Cygwin CDT 在window下开发环境搭建 安装配置与使用 具体图文解说
    Linux高性能server编程——定时器
    OpenGL进阶演示样例1——动态画线(虚线、实线、颜色、速度等)
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14449349.html
Copyright © 2020-2023  润新知