• 1094 The Largest Generation (25 分)


    A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

    Input Specification:

    Each input file contains one test case. Each case starts with two positive integers N (<) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

    ID K ID[1] ID[2] ... ID[K]
     

    where ID is a two-digit number representing a family member, K (>) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

    Sample Input:

    23 13
    21 1 23
    01 4 03 02 04 05
    03 3 06 07 08
    06 2 12 13
    13 1 21
    08 2 15 16
    02 2 09 10
    11 2 19 20
    17 1 22
    05 1 11
    07 1 14
    09 1 17
    10 1 18
     

    Sample Output:

    9 4


    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=1010;
    #define  inf  0x3fffffff
    //vector<vector<int> > v;//此方式不能使用,因为存在某没有子节点的结点,但是v数组一位下标不存在
    vector<int > v[100];
    int num[maxn];
    void dfs(int index,int depth){
        num[depth]++;
        for(int i=0;i<v[index].size();i++){
            dfs(v[index][i],depth+1);
        }
    }
    int main(){
        fill(num,num+maxn,0);
        int n, m, a, k, c;
        scanf("%d %d", &n, &m);
    //    v.resize(n);
        for(int i = 0; i < m; i++) {
            scanf("%d %d",&a, &k);
            for(int j = 0; j < k; j++) {
                scanf("%d", &c);
                v[a].push_back(c);
            }
        }
        dfs(1, 1);
        int maxnum=-1;
        int maxdep=0;
        for(int i=1;i<=maxn;i++){
            if(num[i]>maxnum){
                maxnum=num[i];
                maxdep=i;
            }
        }
        printf("%d %d",maxnum,maxdep);
        return 0;
    }
  • 相关阅读:
    String空格删除和java删除字符串最后一个字符的几种方法
    Ceph 12.2.0 实践osd 智能分组功能
    Ceph 12.2.0 实践osd 智能分组功能
    Ceph 12.2.0 实践osd 智能分组功能
    Ceph 12.2.0 实践osd 智能分组功能
    取区域/扇区边界点
    取区域/扇区边界点
    取区域/扇区边界点
    取区域/扇区边界点
    解决客户端向服务器数据库传输中文乱码的方法
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14438879.html
Copyright © 2020-2023  润新知