• 1101 Quick Sort (25 分)


    There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

    For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

    • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
    • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
    • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
    • and for the similar reason, 4 and 5 could also be the pivot.

    Hence in total there are 3 pivot candidates.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then the next line contains N distinct positive integers no larger than 1. The numbers in a line are separated by spaces.

    Output Specification:

    For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

    Sample Input:

    5
    1 3 2 4 5
     

    Sample Output:

    3
    1 4 5

    问题代码:
    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=10000010;
    int m[maxn];
    int mm[maxn];
    int main(){
        int n;
        cin>>n;
        set<int> s;
        for(int i=0;i<n;i++){
            cin>>m[i];
            mm[i]=m[i];
        }
        sort(m,m+n);
        for(int i=0;i<n;i++){
            if(mm[i]==m[i]){
                s.insert(mm[i]);
            }
        }
        cout<<s.size()<<endl;
        set<int>::iterator it;
        it=s.begin();
        cout<<*it;
        it++;
        for(;it!=s.end();it++){
            cout<<" "<<*it;
        }
        return 0;
    
    }

    后续再改进。。。

  • 相关阅读:
    Clean Code之JavaScript代码示例
    Okhttp3发送xml、json、文件的请求方法
    Ubuntu16.04 开机显示The system is running in low-graphics mode
    DELL R730服务器配置RAID及安装服务器系统 以及域的控制
    centos7搭建rsync
    centos7环境变量配错导致命令不能用
    centos7用lvm扩展xfs文件系统的根分区
    centos查看CPU的数量
    centos7无故重启-内核升级
    ubuntu scp命令或者用root连接ssh提示:Permission denied, please try again.错误
  • 原文地址:https://www.cnblogs.com/dreamzj/p/14414248.html
Copyright © 2020-2023  润新知