• POJ 3370 Halloween treats


    Halloween treats
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 4979   Accepted: 1876   Special Judge

    Description

    Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

    Your job is to help the children and present a solution.

    Input

    The input contains several test cases.
    The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

    The last test case is followed by two zeros.

    Output

    For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

    Sample Input

    4 5
    1 2 3 7 5
    3 6
    7 11 2 5 13 17
    0 0

    Sample Output

    3 5
    2 3 4
    //抽屉原理---同上一篇POJ2356是一个类型,不过本题要求输出的是编号
    #include <cstdio>
    #include <cstring>
    #include <iostream>
    
    using namespace std;
    
    const int MAX = 100001;
    int pos[MAX];
    
    void print(int begin, int end)
    {
        while(begin < end)
            printf("%d ", begin++);
        printf("%d\n", begin);
    }
    
    int main()
    {
        int n, m, sum, t, begin, end;
        bool flag;
        while(scanf("%d %d", &n, &m), n || m)
        {
            memset(pos, -1, sizeof(pos));
            flag = false;
            sum = 0;
            for(int i = 1; i <= m; ++i)
            {
                scanf("%d", &t);
                if(flag)
                    continue;
                sum = (sum + t) % n;
                if(sum == 0)
                {
                    begin = 1;
                    end = i;
                    flag = true;
                    continue;
                }
                if(pos[sum] != -1)
                {
                    begin = pos[sum] + 1;
                    end = i;
                    flag = true;
                    continue;
                }
                pos[sum] = i;
            }
            print(begin, end);
        }
        return 0;
    }
    

      




    功不成,身已退
  • 相关阅读:
    Python3之命令行参数处理
    基于 Laradock 环境 Project 的总结
    Typora功能新发现-自动复制图片到指定目录下
    ubuntu 18.04 设置静态ip方法
    vscode 同时编辑多处,多个光标 快捷键
    nginx和ftp搭建图片服务器
    Centos 6.5出现yum安装慢的情况
    Linux中的CentOS 6克隆之后修改
    springMVC-文件上传CommonsMultipartFile
    Spring和mybatis整合 org.mybatis.spring.mapper.MapperScannerConfigurer
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2753078.html
Copyright © 2020-2023  润新知