• HDU3835 R(N)


    R(N)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1412    Accepted Submission(s): 729


    Problem Description
    We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,
    10=(-3)^2+1^2.
    We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).
     
    Input
    No more than 100 test cases. Each case contains only one integer N(N<=10^9).
     
    Output
    For each N, print R(N) in one line.
     
    Sample Input
    2 6 10 25 65
     
    Sample Output
    4 0 8 12 16
    Hint
    For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)
     
    //求给定整数n可以分解成多少种情况使得n=x^2+y^2(x与y均为整数)
    #include<stdio.h>
    #include<math.h>
    
    int main()
    {
    	int k,i,j,n,ans;
    	while(~scanf("%d",&n))
    	{
    		if(!n)
    		{
    			printf("1\n");
    			continue;
    		}
    		ans=0;
    		k=(int)sqrt(n/2.0);
    		for(i=0;i<=k;++i)
    		{
    			j=(int)sqrt(n-i*i);
    			if(i*i+j*j==n)
    			{
    				if(i==j||i==0||j==0)  //其中有一个为0或者x==y时候只有四种情况
    					ans+=4;
    				else
    					ans+=8;    //x与y不为0且不相等的时候有8种情况
    			}
    		}
    		printf("%d\n",ans);
    	}
    	return 0;
    }
    

      

    功不成,身已退
  • 相关阅读:
    django用户认证系统——基本设置1
    django用户认证系统——注册3
    django数据库设计
    修改linux最大文件句柄数
    LoadRunner监控Linux
    MySQL设置密码的三种方法
    JMeter学习-021-JMeter 定时器的应用
    mysql-bin.000001文件的来源及处理方法【转】
    js读取解析JSON数据
    关于查询区域标注区域总结
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2685813.html
Copyright © 2020-2023  润新知