• 六月月赛F题


    题目信息:
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input

    The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

    Output

    are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0
    

    Sample Output

    0
    1
    2
    2
    
    
    #include<iostream>
    #include<cstring>
    char map[105][105];
    int m,n;
    using namespace std;
    
    void DFS(int i,int j)
    {
    	if(map[i][j]=='@')
    	{
    		map[i][j]='*';
    		if(i-1>0&&map[i-1][j]=='@')
    			DFS(i-1,j);
    		if(i+1<=m&&map[i+1][j]=='@')
    			DFS(i+1,j);
    		if(j-1>0&&map[i][j-1]=='@')
    			DFS(i,j-1);
    		if(j+1<=n&&map[i][j+1]=='@')
    			DFS(i,j+1);
    		if(i-1>0&&j-1>0&&map[i-1][j-1]=='@')
    			DFS(i-1,j-1);
    		if(i-1>0&&j+1<=n&&map[i-1][j+1]=='@')
    			DFS(i-1,j+1);
    		if(i+1<=m&&j-1>0&&map[i+1][j-1]=='@')
    			DFS(i+1,j-1);
    		if(i+1<=m&&j+1<=n&&map[i+1][j+1]=='@')
    			DFS(i+1,j+1);
    	}
    }
    
    int main()
    {
    	int i,j,count;
    	while(cin>>m>>n)
    	{
    		count=0;
    		if(m==0)
    			break;
    		for(i=1;i<=m;++i)
    		{
    			for(j=1;j<=n;++j)
    			{
    				cin>>map[i][j];
    			}
    		}
    		for(i=1;i<=m;++i)
    		{
    			for(j=1;j<=n;++j)
    			{
    				if(map[i][j]=='@')
    				{
    					++count;
    					DFS(i,j);
    				}
    			}
    		}
    		cout<<count<<endl;
    	}
    	return 0;
    }
    
    功不成,身已退
  • 相关阅读:
    Enterprise Library系列文章回顾与总结
    .NET设计模式系列文章
    从Google趋势看.NET下的Ajax框架
    Atlas学习手记(18):使用DragPanel实现拖放面板
    Atlas学习手记(2):全面了解ScriptManager
    .NET设计模式(17):命令模式(Command Pattern)
    Atlas学习手记(3):由UpdatePanel开始
    Atlas学习手记(16):使用PasswordStrength检测密码强度
    Atlas学习手记(17):使用FilteredTextBox过滤字符
    用Windows Live Writer在博客园发布Post
  • 原文地址:https://www.cnblogs.com/dongsheng/p/2559248.html
Copyright © 2020-2023  润新知