• Lweb and String 超级大水题


    Lweb and String

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 261    Accepted Submission(s): 174


    Problem Description
    Lweb has a string S.

    Oneday, he decided to transform this string to a new sequence. 

    You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing). 

    You need transform every letter in this string to a new number.

    A is the set of letters of SB is the set of natural numbers. 

    Every injection f:AB can be treat as an legal transformation. 

    For example, a String “aabc”, A={a,b,c}, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3. 

    Now help Lweb, find the longest LIS which you can obtain from S.

    LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
     
    Input
    The first line of the input contains the only integer T,(1T20).

    Then T lines follow, the i-th line contains a string S only containing the lowercase letters, the length of S will not exceed 105.
     
    Output
    For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
     
    Sample Input
    2 aabcc acdeaa
     
    Sample Output
    Case #1: 3 Case #2: 4
     
    Author
    UESTC
     
    Source
     
     
    题意:给你一个字符串, 你把它转换成数字,然后求最大递增子序列。
     
    大坑, 一直在求最大递增子序列, 一直WA, 最后发现连最大递增子序列也不用求了, 算出字符串中26个小写字母有几个就行了。
     
    代码:

    #include<stdio.h>
    #include<string.h>
    #define N 10000006

    char s[N];
    int a[N];

    int main(void)
    {
    int t, ans, i, j;

    scanf("%d", &t);

    j = 0;
    while(t--)
    {
    j++;
    ans = 0;
    memset(a, 0, sizeof(a));
    scanf("%s", s);

    int n = strlen(s);

    for(i = 0; i < n; i++)
    a[s[i] - 'a' + 1]++;

    for(i = 1; i <= 26; i++)
    {
    if(a[i])//判断26个英文字母是否出现过, 出现过长度就加1.
    ans++;

    }

    printf("Case #%d: %d ", j, ans);
    }

    }

     
     
    Recommend
    wange2014   |   We have carefully selected several similar problems for you:  5842 5841 5840 5839 5838 
  • 相关阅读:
    【Unity 3D】学习笔记29:游戏的例子——简单的小制作地图
    mysql位_01检查错误代码的方法
    编程获取linuxservercpu、内存和磁盘使用
    poj 2482 Stars in Your Window(扫描线)
    Largest Rectangle in Histogram
    【剑指offer】删除字符也出现在一个字符串
    linux sdio card睡眠治疗 sdio card removed解决方案
    Wooyun
    APT攻击
    Elasticsearch 学习~
  • 原文地址:https://www.cnblogs.com/dll6/p/5771961.html
Copyright © 2020-2023  润新知