• Bookshelf 2 01背包


    B - Bookshelf 2
    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
    Submit Status

    Description

    Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

    FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

    To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

    Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

    Input

    * Line 1: Two space-separated integers: N and B
    * Lines 2..N+1: Line i+1 contains a single integer: Hi

    Output

    * Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

    Sample Input

    5 16
    3
    1
    3
    5
    6

    Sample Output

    1


    题意:有N 头牛,书架高度M, 列举每头牛的高度, 求牛叠加起来的超过书架的最小高度。

    题目思路:求出奶牛叠加能达到的所有高度,并用dp[]保存,最后进行遍历,找出与h差最小的dp[]即所求答案。

    代码:

    #include<stdio.h>
    #include<string.h>
    #define max(a, b)(a > b ? a : b)
    #define N 1000010

    int main(void)
    {
    int dp[N];
    int i, j, n, m;
    int w[N];

    while(scanf("%d%d", &n, &m) != EOF)
    {
    int sum = 0;//所有牛加起来的总高度。
    memset(dp, 0, sizeof(dp));
    for(i = 1; i <= n; i++)
    {
    scanf("%d", &w[i]);
    sum += w[i];
    }
    int ans = 0;
    for(i = 1; i <= n; i++)
    {
    for(j = sum; j >= w[i]; j--)//j要倒推才能保证在推dp[j]时, max里dp[j]和dp[j-w[i]]保存的是状态dp[i-1][j] 和dp[i-1][j-w[i]]的值。
    {

    dp[j] = max(dp[j], dp[j-w[i]] + w[i]);

    }
    }
    for(i = 1; i <= sum; i++)//遍历dp数组找到超过书架的最小高度直接保存跳出循环。
    {
    if(dp[i] >= m)
    {
    ans = dp[i];
    break;
    }

    }

    printf("%d ", ans - m);

    }

    return 0;
    }






  • 相关阅读:
    Cannot find the class file for java.lang.Object错误
    JAVA 基础 八种数据类型
    获取转发前的uri与jsp:include的uri
    web 应用获取mybatis sqlSessionFactory 扫描保存的的sqlMapper
    Spring MVC 3 试用笔记——helloworld
    Struts2 Plugin 试用笔记
    JavaScript面试题(评解为原创)
    DataSet的Table筛选多条件情况用法
    每日一帖,记录技术点滴
    行内元素和块级元素的区别
  • 原文地址:https://www.cnblogs.com/dll6/p/5742705.html
Copyright © 2020-2023  润新知