• PAT-GPLT L1-035


    题目链接:https://www.patest.cn/contests/gplt/L1-035

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    8000 B
    判题程序
    Standard
    作者
    陈越

    以上是朋友圈中一奇葩贴:“2月14情人节了,我决定造福大家。第2个赞和第14个赞的,我介绍你俩认识…………咱三吃饭…你俩请…”。现给出此贴下点赞的朋友名单,请你找出那两位要请客的倒霉蛋。

    输入格式:

    输入按照点赞的先后顺序给出不知道多少个点赞的人名,每个人名占一行,为不超过10个英文字母的非空单词,以回车结束。一个英文句点“.”标志输入的结束,这个符号不算在点赞名单里。

    输出格式:

    根据点赞情况在一行中输出结论:若存在第2个人A和第14个人B,则输出“A and B are inviting you to dinner...”;若只有A没有B,则输出“A is the only one for you...”;若连A都没有,则输出“Momo... No one is for you ...”。

    输入样例1:
    GaoXZh
    Magi
    Einst
    Quark
    LaoLao
    FatMouse
    ZhaShen
    fantacy
    latesum
    SenSen
    QuanQuan
    whatever
    whenever
    Potaty
    hahaha
    .
    
    输出样例1:
    Magi and Potaty are inviting you to dinner...
    
    输入样例2:
    LaoLao
    FatMouse
    whoever
    .
    
    输出样例2:
    FatMouse is the only one for you...
    
    输入样例3:
    LaoLao
    .
    
    输出样例3:
    Momo... No one is for you ...
     
    题解:
    emmmmm,我觉得有时候就是应该用这样的水题,来伪装自己的博客有很多博文的样子。
     
    AC代码:
    #include<bits/stdc++.h>
    using namespace std;
    string name;
    string unlucky1,unlucky2;
    int main()
    {
        int cnt=0;
        while(cin>>name)
        {
            if(name[0]=='.') break;
    
            cnt++;
            if(cnt==2) unlucky1=name;
            if(cnt==14) unlucky2=name;
        }
    
        if(cnt>=14)
            cout<<unlucky1<<" and "<<unlucky2<<" are inviting you to dinner..."<<endl;
        else if(cnt>=2)
            cout<<unlucky1<<" is the only one for you..."<<endl;
        else
            cout<<"Momo... No one is for you ..."<<endl;
    }
  • 相关阅读:
    读取指定文件夹中的指定类型文件
    Java中字符串比较的注意点
    Access数据库 更新 "延时" 现象
    sqlserver版本分类下载以及各个版本之间的区别是什么
    android.os.NetworkOnMainThreadException
    Android模拟器分辨率介绍
    DataReader 绑定DataGridView有两种方式
    安装完Linux Mint后,发现系统中竟没有中文输入法
    处理EXCEL11问题
    windowplayer播放列表属性
  • 原文地址:https://www.cnblogs.com/dilthey/p/8638732.html
Copyright © 2020-2023  润新知