• 中国MOOC_零基础学Java语言_第2周 判断_2信号报告


    2

    信号报告(5分)

    题目内容:

    无线电台的RS制信号报告是由三两个部分组成的:

    R(Readability) 信号可辨度即清晰度.

    S(Strength)    信号强度即大小.

    其中R位于报告第一位,共分5级,用1—5数字表示.

    1---Unreadable

    2---Barely readable, occasional words distinguishable

    3---Readable with considerable difficulty

    4---Readable with practically no difficulty

    5---Perfectly readable

    报告第二位是S,共分九个级别,用1—9中的一位数字表示

    1---Faint signals, barely perceptible

    2---Very weak signals

    3---Weak signals

    4---Fair signals

    5---Fairly good signals

    6---Good signals

    7---Moderately strong signals

    8---Strong signals

    9---Extremely strong signals

    现在,你的程序要读入一个信号报告的数字,然后输出对应的含义。如读到59,则输出:

    Extremely strong signals, perfectly readable.

    输入格式:

    一个整数,信号报告。整数的十位部分表示可辨度,个位部分表示强度。输入的整数范围是[11,59]内有效的数字,这个范围外的数字不可能出现在测试数据中。

    输出格式:

    一句话,表示这个信号报告的意义。按照题目中的文字,先输出表示强度的文字,跟上逗号和空格,然后是表示可辨度的文字,跟上句号。注意可辨度的句子的第一个字母是小写的。注意这里的标点符号都是英文的。

    输入样例:

    33

    输出样例:

    Weak signals, readable with considerable difficulty.

    时间限制:500ms内存限制:32000kb
    import java.util.Scanner;
    
    public class Main {
    	public static void main(String args[]) {
    		int x = 0;
    		int readability;// R(Readability) 信号可辨度即清晰度
    		int strength;// S(Strength) 信号强度即大小
    		Scanner in = new Scanner(System.in);
    		x = in.nextInt();
    		readability = x / 10;
    		strength = x % 10;
    
    		switch (strength) {
    		case 1:
    			System.out.print("Faint signals, barely perceptible, ");
    			break;
    		case 2:
    			System.out.print("Very weak signals, ");
    			break;
    		case 3:
    			System.out.print("Weak signals, ");
    			break;
    		case 4:
    			System.out.print("Fair signals, ");
    			break;
    		case 5:
    			System.out.print("Fairly good signals, ");
    			break;
    		case 6:
    			System.out.print("Good signals, ");
    			break;
    		case 7:
    			System.out.print("Moderately strong signals, ");
    			break;
    		case 8:
    			System.out.print("Strong signals, ");
    			break;
    		case 9:
    			System.out.print("Extremely strong signals, ");
    			break;
    		}
    
    		switch (readability) {
    		case 1:
    			System.out.print("unreadable.");
    			break;
    		case 2:
    			System.out.print("barely readable, occasional words distinguishable.");
    			break;
    		case 3:
    			System.out.print("readable with considerable difficulty.");
    			break;
    		case 4:
    			System.out.print("readable with practically no difficulty.");
    			break;
    		case 5:
    			System.out.print("perfectly readable.");
    			break;
    		}
    	}
    }
    
  • 相关阅读:
    关于页面跳转
    javascript之继承
    ubuntu+mysql+php+apache2+wordpress建站全记录
    Vue双向绑定原理解析
    Excel导入
    Excel文件下载(导出)
    IDEA创建Activiti工作流(集成的方式,生成表)
    git基本操作
    git中分支操作
    整合dubbo的依赖
  • 原文地址:https://www.cnblogs.com/denggelin/p/6529769.html
Copyright © 2020-2023  润新知