• 括号匹配


    Description

    We give the following inductive definition of a “regular brackets” sequence:

    • the empty sequence is a regular brackets sequence,
    • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
    • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
    • no other sequence is a regular brackets sequence

    For instance, all of the following character sequences are regular brackets sequences:

    (), [], (()), ()[], ()[()]

    while the following character sequences are not:

    (, ], )(, ([)], ([(]

    Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

    Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

    Input

    The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

    Output

    For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

    Sample Input

    ((()))
    ()()()
    ([]])
    )[)(
    ([][][)
    end

    Sample Output

    6
    6
    4
    0
    6


    
    
    #include<iostream>
    #include<string>
    using namespace std;
    int d[105][105];
    int n;
    string s;
    void dp(){
    for(int i=0;i<n;i++){d[i+1][i]=0;d[i][i]=1;}
        for(int i=n-2;i>=0;i--){
            for(int j=i+1;j<n;j++){
                d[i][j]=n;
                if(s[i]=='('&&s[j]==')'||s[i]=='['&&s[j]==']')d[i][j]=min(d[i][j],d[i+1][j-1]);
                for(int k=i;k<j;k++){
                    d[i][j]=min(d[i][j],d[i][k]+d[k+1][j]);
                }
            }
        }
    }
    int main(){
        while(cin>>s){
            n=s.length();
            if(s=="end")break;
            dp();
            cout<<n-d[0][n-1]<<endl;
        }
    return 0;
    }
    View Code
  • 相关阅读:
    docker部署mysql Navicat远程连接
    window10安装nginx及请求转发到tomcat服务器访问项目及开机自启
    Keras笔记
    Spectral Clustering 并用silhouette指标值确定最优聚类数目
    Java Swing, paint(), paintComponent(), repaint()
    tensorflow(一):安装在Spyder上
    人工智能入门(七):artificial neural network
    人工智能入门(六):SVM
    人工智能入门(五):data mining的一些算法
    人工智能入门(四):uncertainty&基于统计的学习
  • 原文地址:https://www.cnblogs.com/demodemo/p/4732586.html
Copyright © 2020-2023  润新知