• POJ 2250(最长公共子序列 变形)


    Description

    In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

    Therefore the German government requires a program for the following task: 
    Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

    Your country needs this program, so your job is to write it for us.

    Input

    The input will contain several test cases. 
    Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
    Input is terminated by end of file.

    Output

    For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

    Sample Input

    die einkommen der landwirte
    sind fuer die abgeordneten ein buch mit sieben siegeln
    um dem abzuhelfen
    muessen dringend alle subventionsgesetze verbessert werden
    #
    die steuern auf vermoegen und einkommen
    sollten nach meinung der abgeordneten
    nachdruecklich erhoben werden
    dazu muessen die kontrollbefugnisse der finanzbehoerden
    dringend verbessert werden
    #
    

    Sample Output

    die einkommen der abgeordneten muessen dringend verbessert werden


    题意: 这个题目和书上的Lcs 问题差不多 但是他的元素不再是字符
    变成了 每个元素都是单词也就是字符串
    方程:
    LCS(i,j)表示数组以数组1的i个为止和以数组2的第j个为止的最长公共子序列,注意是第i个字符为子串的末尾字符(这样才能达到无后效性的目的)
    1.LCS(i-1,j-1)+1 (a【i】=b【j】)
    LCS(i,j)={
    2.max{LCS(i-1,j),LCS(i,j-1)} (a【i】!=b【j】)
    #include<iostream>
    #include<cstring>
    #include<string>
    #include<vector>
    using namespace std;
    
    vector<string> st1,st2;
    int dp[110][110],path[110][110];
    int tag;
    
    void printpath(int x,int y){
        if(x==0||y==0) return;
        if(path[x][y]==1){
            printpath(x-1, y-1);
            if(tag==0){
                cout<<st1[x-1];
                tag=1;
            }
            else cout<<" "<<st1[x-1];
        }
        else if(path[x][y]==2) printpath(x-1, y);
        else if(path[x][y]==3)printpath(x, y-1);
    }
    
    int main(){
        string str;
        while(cin>>str){
            st1.clear();st2.clear();
            st1.push_back(str);
            while(cin>>str&&str!="#") st1.push_back(str);
            while(cin>>str&&str!="#") st2.push_back(str);
            memset(dp,0,sizeof(dp));
            memset(path,0,sizeof(path));
            int len1=st1.size(),len2=st2.size();
            tag=0;
            for(int i=1;i<=len1;i++){
                for(int j=1;j<=len2;j++){
                        if(st1[i-1]==st2[j-1]){
                            dp[i][j]=dp[i-1][j-1]+1;
                            path[i][j]=1;
                        }else if(dp[i-1][j]>dp[i][j-1]){
                            dp[i][j]=dp[i-1][j];
                            path[i][j]=2;
                        }else{
                            dp[i][j]=dp[i][j-1];
                            path[i][j]=3;
                        }
                  }
              }
            printpath(len1, len2);
            cout<<endl;
        }
    return 0;
    }
    View Code
  • 相关阅读:
    work two year[转]
    知名技术博客内容聚合网站
    VS2010注册码
    某公司的一个题面试题(wfcfan)
    asp.net控件开发基础系列
    .NET (C#) Internals: Delegates1
    可空类型细微见真知!
    C#中操作XML Node节点细节操作
    sql server数据库性能的优化
    字符串精确匹配算法改进的探讨
  • 原文地址:https://www.cnblogs.com/demodemo/p/4732496.html
Copyright © 2020-2023  润新知