• 杭电1005


    Number Sequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 62216    Accepted Submission(s): 14226


    Problem Description
    A number sequence is defined as follows:

    f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

    Given A, B, and n, you are to calculate the value of f(n).
     

    Input
    The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
     

    Output
    For each test case, print the value of f(n) on a single line.
     

    Sample Input
    1 1 3 1 2 10 0 0 0
     

    Sample Output
    2 5
     

    Author
    CHEN, Shunbao
     

    Source
     

    Recommend
    JGShining



    #include <iostream>
    #include <vector>
    using namespace std;
    
    void fn(int A, int B, int n);
    void fn(int A, int B, int n)
    {
        
        int cirlce[50];
        cirlce[1] = 1;
        cirlce[2] = 1;
        if (n == 1 || n == 2)  
        {
            cout << 1 << endl;
            return;
        }
        int i;
        for ( i = 3;i < 50 ; ++ i) //找到循环节
        {
            cirlce[i] = (A*cirlce[i -1] + B*cirlce[i -2])%7;
            if (cirlce[i -1] == 1 && cirlce[ i ] ==1)
                break;
        }
        if (n%(i -2) == 0)
        {
            cout << cirlce[i -2]<< endl;
        }
        else
        {
            cout << cirlce[n%(i -2)] << endl;
        }
    }
    
    
    int main(int argc, char **argv)
    {
        int A, B, n;
        while (cin>>A>>B>>n) {
            if (A == 0 && B == 0 && n == 0)
                break;
            fn(A, B, n);
            
        }
        return 0;
    }
    


  • 相关阅读:
    CAD中导入.pat文件
    使用solid works 助力NBA | 操作案例
    Java关键字---this的由来和其三大作用
    关于solid works中的:动态链接库(DLL)初始化例失败的解决方法
    基于51单片机的keli安装方法
    wintc的安装方法
    文件处理2
    文件处理1
    CAD绘制篮球教程
    数据分析之Numpy
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405222.html
Copyright © 2020-2023  润新知