• 杭电1015




    Safecracker

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4682    Accepted Submission(s): 2327


    Problem Description
    === Op tech briefing, 2002/11/02 06:42 CST === 
    "The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

    v - w^2 + x^3 - y^4 + z^5 = target 

    "For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

    === Op tech directive, computer division, 2002/11/02 12:30 CST === 

    "Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
     

    Sample Input
    1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
     

    Sample Output
    LKEBA YOXUZ GHOST no solution
     



    //杭电1015
    #include <iostream>
    #include <math.h>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    char letters[13];
    char result[6];
    unsigned long target;
    
    bool cmp(const char &a,const char &b) {
        return (b-a)>=0?false:true;
    }  
    
    
    int main()
    {
        
    	while ((cin >> target >> letters) )
    	{
            if (target == 0 && !strcmp(letters, "END"))
                break;
            
    		int len = strlen(letters);
    		sort(letters, letters + len, cmp);
    		bool find = false;
            int V,W,X,Y,Z;
    		for (int v = 0 ; v < len ; ++ v)
            {
                V = letters[v] - 64;
    			for (int w = 0; w < len ; ++ w)
                {
                    if (w == v)continue;
                    W = letters[w] - 64;
    				for (int x = 0; x < len ; ++ x)
                    {
                        if (x == w || x == v)continue;
                        X = letters[x] - 64;
    					for (int y = 0; y < len  ; ++ y)
                        {
                            if (y == x || y == w || y == v)continue;
                            Y = letters[y] - 64;
    						for (int z = 0; z < len; ++z)
    						{
    							if (z == y || z == x || z == w|| z == v)
    								continue;
                                Z = letters[z] - 64;
    							unsigned long temp = V - W*W + X*X*X - Y*Y*Y*Y + Z*Z*Z*Z*Z;
    							if (target == temp)
    							{
    								result[0] = letters[v];
    								result[1] = letters[w];
    								result[2] = letters[x];
    								result[3] = letters[y];
    								result[4] = letters[z];
    								result[5] = '\0';
    								find = true;
                                    break;
    							}
    						}
                            if(find)break;
                        }
                        if (find)break;
                    }
                    if(find)break;
                }
                if (find)break;
            }
            
    		if (find)
    			cout << result[0] << result[1]<< result[2] << result[3]<<result[4]<<endl;
    		else
    			cout << "no solution" << endl;
            
    	}
    	return 0;
    }
    
    


  • 相关阅读:
    3(翻译)如何在cocos2d里面使用动画和spritesheet
    Objectivec2.0 每种数据类型定义属性的方法
    cocos2d 入门必备4个基本概念
    如何在Mac上搭建自己的服务器——Nginx
    JN_0001:在微信朋友圈分享时长大于10s的视频
    JN_0002:Win10禁止U盘拷贝文件的方法
    abstract class 和 interface区别
    ref和out
    .Net配置错误页
    Unity3d 物体沿着正七边形轨迹移动
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405214.html
Copyright © 2020-2023  润新知