• 杭电1048


    The Hardest Problem Ever

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13447    Accepted Submission(s): 6123


    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
     

    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

    A single data set has 3 components: 

    Start line - A single line, "START" 

    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

    End line - A single line, "END" 

    Following the final data set will be a single line, "ENDOFINPUT".
     

    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.
     

    Sample Input
    START NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX END START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ END START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ END ENDOFINPUT
     

    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE


    代码如下:

    #include <iostream>
    #include <string>
    using namespace std;
    
    inline bool isUpperAlpha(char ch)
    {
    	return (ch >= 'A' && ch <= 'Z') ;
    	return false ;
    }
    
    void deCipher(string& mesg)
    {
    	for (int i = 0 ; i < mesg.length(); ++ i)
    		if (isUpperAlpha(mesg[i]))
    			mesg[i] = ((mesg[i] - 'A' )+ 26 - 5) % 26 + 'A';
    	cout << mesg << endl;
    }
    
    void process()
    {
    	string start, mesg ,end;
    	while (getline(cin, start))
    	{
    		if (start == "ENDOFINPUT" || start != "START") break ;
    		getline(cin, mesg);
    		deCipher(mesg) ;
    		getline(cin, end) ;
    	}
    }
    
    int main(int argc, char** argv)
    {
    	process() ;
    	return 0 ;
    }




  • 相关阅读:
    【学习总结】测试开发工程师面试指南-软件测试行业分析与职业解析
    【学习总结】测试开发工程师面试指南-汇总
    【JAVA】java中char类型数组用数组名打印结果不是地址值而是数组内容
    Python常见问题合集
    操作系统常见问题合集
    算法题常见问题合集
    个人向常见问题合集
    Linux常见问题合集
    数据结构常见问题合集
    网络常见问题合集
  • 原文地址:https://www.cnblogs.com/dancingrain/p/3405191.html
Copyright © 2020-2023  润新知