• 带权并查集复习-HDU3038


    TT and FF are ... friends. Uh... very very good friends -________-b

    FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

    Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

    Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

    The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

    However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

    What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

    But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

    InputLine 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

    Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

    You can assume that any sum of subsequence is fit in 32-bit integer.
    OutputA single line with a integer denotes how many answers are wrong.Sample Input

    10 5
    1 10 100
    7 10 28
    1 3 32
    4 6 41
    6 6 1

    Sample Output

    1

    很简单的带权并查集,将闭区间[l,r]改为半开区间(l-1,r],进行区间操作
    var
      rep,sum:array[0..200000]of longint;
      n,m,a,i,b,c,ans,l,r:longint;
    function getrep(x:longint):longint;
    var fa:longint;
    begin
      if(x=rep[x])then
      begin
        exit(x);
      end;
      fa:=rep[x];
      rep[x]:=getrep(rep[x]);
      sum[x]:=sum[x]+sum[fa];
      exit(rep[x]);
    end;
    begin
    
      while(not eof)   do
      begin
        readln(n,m);
        ans:=0;
        for i:=0 to n do
        begin
          rep[i]:=i;
          sum[i]:=0;
        end;
        for i:=1 to m do
        begin
          readln(a,b,c);
          dec(a);
    
          if(getrep(a)=getrep(b))   then
          begin
            if(sum[b]-sum[a]<>c)   then
            inc(ans);
          end else
          begin
    
            l:=getrep(a);r:=getrep(b);
            rep[r]:=l;
            sum[r]:=sum[a]+c-sum[b];
          end;
        end;
        writeln(ans);
      end;
    end.

    c++的

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    #define N 200000+10
    int rep[N],sum[N];
    
    int getrep(int x)
    {
        if(rep[x]==x) 
          return x;
          int f=rep[x];
        rep[x]=getrep(rep[x]);
        sum[x]+=sum[f];
        return rep[x];
    }
    
    int main()
    {
        int n,m;
        while(~scanf("%d%d",&n,&m))
        {
        int ans=0;
        //cin>>n>>m;
        for(int i=0;i<=n;i++) 
        rep[i]=i,sum[i]=0;
        for(int i=1;i<=m;i++)
        {
            int l,r,s;
            scanf("%d%d%d",&l,&r,&s);
            l--;
            int L=getrep(l),R=getrep(r);
            if(L==R)
            {
               if(sum[l]-sum[r]!=s)ans++;
            }else
            {
                rep[L]=R;
                sum[L]=sum[r]-sum[l]+s;
            }
        }
        cout<<ans<<endl;
        }
    }
  • 相关阅读:
    设计带构造函数的Dog类 代码参考
    动态生成Person类的对象 代码参考
    Fragment传值
    Fragment的创建
    显示Intent和隐式Intent
    Intent及其七大属性及intent-filter设置
    Activity传值的几种方式
    认识Activity
    GridView的基本使用
    Spinner的基本使用
  • 原文地址:https://www.cnblogs.com/dancer16/p/6917894.html
Copyright © 2020-2023  润新知