• D


    We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
    Now there is a very easy problem . I think you can AC it.
      We can define sum(n) as follow:
      if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
      Is it very easy ? Please begin to program to AC it..-_-

    Input  The input file contains multilple cases.
      Every cases contain only ont line, every line contains a integer n (n<=100000).
      when n is a negative indicate the end of file.Output  output the result sum(n).
    Sample Input

    1
    2
    3
    -1

    Sample Output

    1
    3
    30

    刚开始看题里面用递归!就用了递归发现超内存了。于是就打表了。注意了,下次可以吸取这次的经验。
    #include<iostream>
    using namespace std;
    #define N 100002
    int main()
    {
    long long num[N],i;
    num[0] = 0;
    for ( i = 1; i < N; i++)
    {
    if (i % 3) num[i]=num[i - 1] + i;
    else num[i]=num[i - 1] + i*i*i;
    }
    int n;
    while (cin >> n)
    {
    if (n < 0) break;
    cout << num[n] << endl;
    }
    return 0;
    }


  • 相关阅读:
    使用vue-cli脚手架搭建简单项目框架
    总结HTML5
    导出网页内容
    vue 编写插件
    各ui库项目结构
    webpack 模块方法
    webpack4.0
    webapp优化
    http/2.0与http/1.1的区别
    setTimeout与Promise的区别
  • 原文地址:https://www.cnblogs.com/damaoranran/p/8778264.html
Copyright © 2020-2023  润新知