In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the i th row and j th column should be the product(乘积) of i and j.
InputThe first line of input is an integer C which indicate the number of test cases.
Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
OutputFor each test case, print out the multiply table.
Sample Input
2 1 4
Sample Output
1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16
这是一道水题,但是一道水题还是有东西的,比如这个其实是数学上的一个技巧,emmm,具体是什么我忘了,但是这个方法可以变形的。
这个方法可以解决概率等一些抽象的数学问题,反正就是将抽象化的直观的解题手段(在数学上)
#include<iostream>
using namespace std;
int main()
{
int datanum;
cin >> datanum;
while (datanum--)
{
int num;
cin >> num;
for (int i = 1; i <= num; i++)
{
for (int j = 1; j <= num; j++)
{
cout << i*j;
if (j < num) cout << " ";
}
cout << endl;
}
}
return 0;
}