• POJ-1458 Common Subsequence(线性动规,最长公共子序列问题)


    Common Subsequence
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 44464 Accepted: 18186
    Description

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    Input

    The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
    Output

    For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
    Sample Input

    abcfbc abfcab
    programming contest
    abcd mnp
    Sample Output

    4
    2
    0

    裸的最长公共子序列问题:
    状态转移方程:
    if(s1[i]==s2[j])
    dp[i][j]=dp[i-1][j-1]+1;
    else
    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

    #include <iostream>
    #include <string.h>
    #include <algorithm>
    #include <math.h>
    #include <stdlib.h>
    #include <string>
    
    using namespace std;
    char s1[300];
    char s2[300];
    int dp[300][300];
    int main()
    {
    
        while(scanf("%s%s",&s1,&s2)!=EOF)
        {
            int len1=strlen(s1);
            int len2=strlen(s2);
                     memset(dp,0,sizeof(dp));
            for(int i=0;i<len1;i++)
            {
                for(int j=0;j<len2;j++)
                {
                    if(s1[i]==s2[j])
                        dp[i+1][j+1]=dp[i][j]+1;
                    else
                        dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
    
                }
            }
            cout<<dp[len1][len2]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Java开发常用知识点总结
    Net实现阿里云开放云存储服务(OSS)
    KEIL MDK-ARM Version 5.26正式版开发工具下载
    【NXP开发板应用—智能插排】4. PWM驱动
    【NXP开发板应用—智能插排】3.驱动GPIO点亮外接LED
    【NXP开发板应用—智能插排】2.初步解析example之GPI
    【NXP开发板应用—智能插排】1.如何使用scp传输文件
    Keil MDK最新版 5.25介绍及下载地址
    springmvc框架helloword
    单例设计模式
  • 原文地址:https://www.cnblogs.com/dacc123/p/8228842.html
Copyright © 2020-2023  润新知