• PAT 1006 Sign In and Sign Out


    1006. Sign In and Sign Out (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

    Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:
    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
    Sample Output:

    SC3021234 CS301133

    题意是要求你求出最先到的和最后走到

    #include <iostream>
    #include <string.h>
    #include <stdlib.h>
    #include <stdio.h>
    #include <algorithm>
    #include <math.h>
    #include <queue>
    #include <map>
    #include <strstream>
    #include <string>
    
    using namespace std;
    struct Node
    {
      string s;
      int stime;
      int ltime;
    }a[10005];
    int n;
    int cmp1(Node a,Node b)
    {
      return a.stime<b.stime;
    }
    int cmp2(Node a,Node b)
    {
      return a.ltime>b.ltime;
    }
    int time(int hh,int mm,int ss)
    {
      return hh*3600+mm*60+ss;
    }
    int main()
    {
        scanf("%d",&n);
      int h,m,s;
      for(int i=0;i<n;i++)
      {
        cin>>a[i].s;
        scanf("%d:%d:%d",&h,&m,&s);
        a[i].stime=time(h,m,s);
        scanf("%d:%d:%d",&h,&m,&s);
        a[i].ltime=time(h,m,s);
      }
      sort(a,a+n,cmp1);
      cout<<a[0].s<<" ";
      sort(a,a+n,cmp2);
      cout<<a[0].s<<endl;
    }


  • 相关阅读:
    多线程:多线程设计模式(一):总体介绍
    javascript:12种JavaScript MVC框架之比较
    mysql 查询死锁语句
    charles 抓包工具破解方法
    java 自定义log类
    git统计日期之间的代码改动行数
    mac/linux自带定时任务执行crontab的使用
    python MD5步骤
    python 操作excel读写
    python logger日志工具类
  • 原文地址:https://www.cnblogs.com/dacc123/p/8228623.html
Copyright © 2020-2023  润新知