• hdu 1083 Courses最大匹配


    Courses

     

    Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 


    . every student in the committee represents a different course (a student can represent a course if he/she visits that course) 


    . each course has a representative in the committee 


    Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format: 


    P N 
    Count1 Student1 1 Student1 2 ... Student1 Count1 
    Count2 Student2 1 Student2 2 ... Student2 Count2 
    ...... 
    CountP StudentP 1 StudentP 2 ... StudentP CountP 


    The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 


    There are no blank lines between consecutive sets of data. Input data are correct. 


    The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line. 


    An example of program input and output:
    Input
    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1
    Output
    YES
    NO 
    Sample Input
    2
    3 3
    3 1 2 3
    2 1 2
    1 1
    3 3
    2 1 3
    2 1 3
    1 1
    Sample Output
    YES
    NO 

    题意:如果最大匹配数等于p就是YES否则就是  NO

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<string>
    #define maxn 500
    using namespace std;
    int g[maxn][maxn];
    bool used[maxn];
    int linker[maxn];
    int vn,un;
    bool dfs(int u)
    {
        for(int i=1;i<=vn;i++)
        {
            if(g[u][i]&&!used[i])
            {
                used[i]=true;
                if(linker[i]==-1||dfs(linker[i]))
                {
                    linker[i]=u;
                    return true;
                }
            }
        }
        return false;
    }
    int hungary()
    {
        int res=0;
        memset(linker,-1,sizeof(linker));
        for(int i=1;i<=un;i++)
        {
            memset(used,false,sizeof(used));
            if(dfs(i))res++;
        }
        return res;
    }
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            memset(g,0,sizeof(g));
            cin>>un>>vn;
            for(int i=1;i<=un;i++)
            {
                int x;
                cin>>x;
                for(int j=0;j<x;j++)
                {
                    int y;
                    cin>>y;
                    g[i][y]=1;
                   // g[y][x]=1;
                }
            }
           if(hungary()==un)
            cout<<"YES"<<endl;
           else
            cout<<"NO"<<endl;
        }
    }
    


  • 相关阅读:
    异步IO数据库队列缓存
    Python终端如何输出彩色字体
    pycharm导入本地py文件时,模块下方出现红色波浪线时如何解决
    Python中字典的详细用法
    基于pandas数据预处理基础操作
    进程、线程、协程篇
    面向对象编程进阶
    常用sign算法
    Excel随机生成数据2
    Oracle dbms_random随机数包详解
  • 原文地址:https://www.cnblogs.com/da-mei/p/9053300.html
Copyright © 2020-2023  润新知