• hdu 1829 A Bug's Life



    A Bug's Life 
    Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 17246    Accepted Submission(s): 5521
    Problem Description
    Background 
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

    Problem 
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

    Input

    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
     
    Output

    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

    Sample Input

    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4

    Sample Output

    Scenario #1:
    Suspicious bugs found!

    Scenario #2:
    No suspicious bugs found!

    题意:找出有没有不正常的 匹配,也就是是不是二分图。

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<string>
    #include<vector>
    #define maxn 2010
    using namespace std;
    vector<int>v[maxn];
    int color[1000005];
    int c[1000005];
    bool judge(int u)
    {
        for(int i=0; i<v[u].size(); i++)
        {
            if(color[u]==color[v[u][i]])return false;
            if(color[v[u][i]]==-1)
            {
                color[v[u][i]]=!color[u];
                if(!judge(v[u][i]))
                    return false;
            }
        }
        return true;
    }
    int main()
    {
        int t,w=0;
        scanf("%d",&t);
        while(t--)
        {
            memset(color,-1,sizeof(color));
            memset(c,0,sizeof(c));
            for(int i=0; i<=maxn; i++)
                v[i].clear();
            int n,m;
            w++;
            scanf("%d%d",&n,&m);
            for(int i=0; i<m; i++)
            {
                int a,b;
                scanf("%d%d",&a,&b);
                c[a]=c[b]=1;
                v[a].push_back(b);
                v[b].push_back(a);
            }
            int flag=0;
            for(int i=1; i<=n; i++)
            {
                if(c[i]==1&&color[i]==-1)
                {
                    color[i]=1;
                    if(!judge(i))
                    {
                        flag=1;
                        break;
                    }
                }
            }
            cout<<"Scenario #"<<w<<":"<<endl;
            if(flag==0)
                cout<<"No s";
            else
                cout<<"S";
            cout<<"uspicious bugs found!"<<endl;
            cout<<endl;
        }
    }
    




     


     
  • 相关阅读:
    120-136. 只出现一次的数字
    119-217. 存在重复元素
    118-103. 二叉树的锯齿形层序遍历
    117.力扣-两数相加问题
    116.python处理xmind文件
    115.python获取服务器信息
    日期转换类 DateConverter.java
    数据库连接工具类——包含取得连接和关闭资源 ConnUtil.java
    数据库连接工具类 数据库连接工具类——仅仅获得连接对象 ConnDB.java
    APP手机端加载不到资源服务器后台解决参考
  • 原文地址:https://www.cnblogs.com/da-mei/p/9053299.html
Copyright © 2020-2023  润新知