• nyoj284-坦克大战(搜索 bfs)


    坦克大战

    时间限制:1000 ms  |  内存限制:65535 KB 
    难度:3
    描述 
    Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 
     What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 


     Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
    输入The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
    输出For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

    样例输入

    3 4

    YBEB
    EERE
    SSTE
    0 0

    样例输出

    8

    题意:从Y字母的位置到T字母的位置最少trun了几次(^@^)。遇到R,S不能走,遇到B的话要turn 2次。坑点在必须用优先队列,(hiphop-man:为什么??真的不知道--不喜欢你的style!!!!kkk)

    #include<map>
    #include<set>
    #include<queue>
    #include<math.h>
    #include<vector>
    #include<string>
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    #define inf 0x3f3f3f
    #define ll long long
    #define maxn 350
    using namespace std;
    int m,n;
    struct node{
        int x,y,step;
        bool operator<(const node &a)const{
        return step>a.step;
        }
    }T,S;
    string s[maxn];
    int vis[maxn][maxn];
    int road[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
    bool judge(int x,int y){
        if(x>=0&&y>=0&&x<m&&y<n&&vis[x][y]==0)
            return true;
        return false;
    }
    int bfs(){
       priority_queue<node>q;
       vis[S.x][S.y]=1;
        q.push(S);
        while(!q.empty()){
            S=q.top();
            q.pop();
            int x=S.x,y=S.y,step=S.step;
            for(int i=0;i<4;i++){
                int xx=x+road[i][0];
                int yy=y+road[i][1];
                if(xx==T.x&&yy==T.y)
                return step+1;
                //cout<<xx<<yy<<endl;
                if(judge(xx,yy)&&s[xx][yy]=='E'){
                        vis[xx][yy]=1;S.x=xx;S.y=yy;S.step=step+1;q.push(S);}
                if(judge(xx,yy)&&s[xx][yy]=='B'){
                    vis[xx][yy]=1;S.x=xx;S.y=yy;S.step=step+2;s[xx][yy]='E';q.push(S);}
            }
        }return -1;
    }
    int main(){
        while(~scanf("%d%d",&m,&n)&&(m|n)){
            memset(vis,0,sizeof(vis));
            for(int i=0;i<m;i++){
                cin>>s[i];
                for(int j=0;j<n;j++){
                if(s[i][j]=='Y'){
                    S.x=i;S.y=j;S.step=0;}
                if(s[i][j]=='T'){
                    T.x=i;T.y=j;}
                }
            }cout<<bfs()<<endl;
        }
    }



  • 相关阅读:
    转 | 禁忌搜索算法(Tabu Search)求解带时间窗的车辆路径规划问题详解(附Java代码)
    Branch and price and cut求解传统VRP问题以及VRPTW问题
    标号法(label-setting algorithm)求解带时间窗的最短路问题(ESPPRC)
    运筹学从何学起?如何快速入门精确式算法?
    转 | 模拟退火算法(SA)和迭代局部搜索(ILS)求解TSP的Java代码分享
    用Python画论文折线图、曲线图?几个代码模板轻松搞定!
    45. 截取“测试数据”后面的内容
    44. 更改oracle字符集编码american_america.zh16gbk 改为 SIMPLIFIED CHINESE_CHINA.ZHS16GBK
    18. 浏览器关闭页面时弹出“确定要离开此面吗?”
    6. concat_ws用法
  • 原文地址:https://www.cnblogs.com/da-mei/p/9053271.html
Copyright © 2020-2023  润新知