• L2-009. 抢红包


    没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

    输入格式:

    输入第一行给出一个正整数N(<= 104),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

    K N1 P1 ... NK PK

    其中K(0 <= K <= 20)是发出去的红包个数,Ni是抢到红包的人的编号,Pi(> 0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

    输出格式:

    按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

    输入样例:

    10
    3 2 22 10 58 8 125
    5 1 345 3 211 5 233 7 13 8 101
    1 7 8800
    2 1 1000 2 1000
    2 4 250 10 320
    6 5 11 9 22 8 33 7 44 10 55 4 2
    1 3 8800
    2 1 23 2 123
    1 8 250
    4 2 121 4 516 7 112 9 10
    

    输出样例:

    1 11.63
    2 3.63
    8 3.63
    3 2.11
    7 1.69
    6 -1.67
    9 -2.18
    10 -3.26
    5 -3.26
    4 -12.32


    #include<iostream>
    #include<set>
    #include<map>>
    #include<algorithm>
    using namespace std;
    typedef struct{
    int id;
    int sum;
    int cnt;
    }Price;
    bool cmp(Price p1,Price p2){
    if(p1.sum!=p2.sum)
    return p1.sum>p2.sum?1:0;
    if(p1.cnt!=p2.cnt)
    return p1.cnt>p2.cnt?1:0;
    return p1.id<p2.id?1:0;

    }
    int main(){
    Price price[10000];
    int n;
    cin>>n;
    for(int i =0;i<n;i++ ){
    price[i].id = i;
    price[i].sum = 0;
    price[i].cnt =0;
    }
    for(int i=1;i<=n;i++){
    price[i].id = i;
    int num;
    cin>>num;

    for(int j =0;j<num;j++){
    int qid,cou;
    cin>>qid>>cou;
    price[i].sum-=cou;
    price[qid].sum+=cou;
    price[qid].cnt++;
    }
    }
    sort(price+1,price+1+n,cmp);
    for(int i =1;i<=n;i++){
    cout<<price[i].id<<" ";
    double dou=(double)price[i].sum/100;
    printf("%.2f ",dou);
    }
    return 0;
    }

  • 相关阅读:
    操作系统笔记------处理机调度
    操作系统笔记------进程同步(3)
    体系结构笔记------动态调度中的Tomasulo算法
    体系结构笔记------动态分支预测
    体系结构笔记------MIPS流水线的简单实现
    远程使用内网服务器的tensorboard和jupyter notebook
    tensorflow多分类标签转换成onehot
    anaconda的虚拟环境下,安装和管理python包的方法
    雪伦面经
    tensorflow官方MNIST数据集导入错误解决办法
  • 原文地址:https://www.cnblogs.com/cyj1258/p/8558689.html
Copyright © 2020-2023  润新知