• UVa 674 Coin Change 背包dp




      Coin Change 

    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

    Input 

    The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

    Output 

    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

    Sample Input 

    11
    26
    

    Sample Output 

    4
    13
    


    ------------------



    ----------------

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    const int OO=1e9;
    
    int f[11111];
    int n;
    int a[5]={1,5,10,25,50};
    
    int main()
    {
        while (~scanf("%d",&n))
        {
            memset(f,0,sizeof(f));
            f[0]=1;
            for (int i=0;i<5;i++)
            {
                for (int j=0;j<=n-a[i];j++)
                {
                    if (f[j]) f[j+a[i]]+=f[j];
                }
            }
            printf("%d\n",f[n]);
        }
        return 0;
    }
    





      Coin Change 

    Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


    For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


    Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

    Input 

    The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

    Output 

    For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

    Sample Input 

    11
    26
    

    Sample Output 

    4
    13
    


  • 相关阅读:
    【leetcode】236. 二叉树的最近公共祖先
    【leetcode】230. 二叉搜索树中第K小的元素
    【leetcode】309. 最佳买卖股票时机含冷冻期
    【leetcode】306. 累加数
    【leetcode】304. 二维区域和检索
    spring-framework源码编译及导入
    Java8-函数式接口理解及测试
    Mac编译RocketMQ 4.1.0
    首记
    JS表单验证
  • 原文地址:https://www.cnblogs.com/cyendra/p/3038369.html
Copyright © 2020-2023  润新知