• POJ 3624 Charm Bracelet


      Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

    Output

    * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

    Sample Input

    4 6
    1 4
    2 6
    3 12
    2 7

    Sample Output

    23

    01背包: 直接套模板
    #include <iostream>
    #include <algorithm>
    using namespace std;
    
    int main()
    {
        int w[35000],v[35000],f[35000];
        int n,m,i,j;
        cin>>n>>m;
        for(i=0;i<n;i++)
            cin>>w[i]>>v[i];
        for(i=0;i<n;i++)
        {
            for(j=m;j>=w[i];j--)
                f[j]=max(f[j],f[j-w[i]]+v[i]);
        }
        cout << f[m] << endl;
        return 0;
    }
    

      

  • 相关阅读:
    3.17JSP作业
    JSP第二次作业
    JSP第一次作业
    软件测试课堂练习
    增删改查
    登录界面
    购物商城
    图床
    JSP-2020年4月14日-第七周
    JSP-2020年4月12日-第六周
  • 原文地址:https://www.cnblogs.com/cxbky/p/4727268.html
Copyright © 2020-2023  润新知