• PAT 1116 Come on! Let's C


    1116 Come on! Let's C (20 分)
     

    "Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

    • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
    • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
    • 2、 Everyone else will receive chocolates.

    Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

    Output Specification:

    For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding?instead. If the ID has been checked before, print ID: Checked.

    Sample Input:

    6
    1111
    6666
    8888
    1234
    5555
    0001
    6
    8888
    0001
    1111
    2222
    8888
    2222
    

    Sample Output:

    8888: Minion
    0001: Chocolate
    1111: Mystery Award
    2222: Are you kidding?
    8888: Checked
    2222: Are you kidding?
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    bool is_prime(int x){
        for(int i=2;i <= sqrt(x);i++){
            if(x%i == 0) return false;
        }
        return true;
    }
    
    
    
    
    
    int main(){
    
        int n;
        cin >> n;
        map<string,string> mp;
    
    
        for(int i=1;i <= n;i++){
            string s;
            cin >> s;
            if(i==1){mp[s] = "Mystery Award";}
            else if(is_prime(i)){mp[s] = "Minion";}
            else if(!is_prime(i)){mp[s] = "Chocolate";}
        }
    
        int q;
        cin >> q;
        while(q--){
            string s;
            cin >> s;
            cout << s << ": ";
            if(mp[s] == "")cout << "Are you kidding?"<< endl;
            else if(mp[s] == "Checked") cout << "Checked" << endl;
            else if(mp[s] == "Minion"){
                cout << "Minion" << endl;
                mp[s] = "Checked";
            }
            else if(mp[s] == "Mystery Award"){
                cout << "Mystery Award" << endl;
                mp[s] = "Checked";
            }
            else if(mp[s] == "Chocolate"){
                cout << "Chocolate" << endl;
                mp[s] = "Checked";
            }
    
        }
    
    
    
        return 0;
    }

    白给题,map的运用。

     
  • 相关阅读:
    超实用的 Nginx 极简教程,覆盖了常用场景(转)
    阿里云Redis开发规范(转)
    什么是 AQS ?
    缓存穿透、缓存并发、缓存失效之思路变迁(转)
    看不懂JDK8的流操作?5分钟带你入门(转)
    Redis 分布式锁的正确实现方式(转)
    urllib-Proxy
    基本urllib库
    Windows DOS 命令(持续更新...)
    java 位运算符
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10791578.html
Copyright © 2020-2023  润新知