• PAT 1120 Friend Numbers


    1120 Friend Numbers (20 分)
     

    Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 1.

    Output Specification:

    For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

    Sample Input:

    8
    123 899 51 998 27 33 36 12
    

    Sample Output:

    4
    3 6 9 26
    #include<bits/stdc++.h>
    using namespace std;
    typedef long long ll;
    
    
    
    
    
    int main(){
        int t;
        cin >> t;
        set<int> st;
    
        while(t--){
            string s;
            cin >> s;
            int sum = 0;
            for(int i=0;i < s.size();i++){
                sum += s[i] - '0';
            }
            st.insert(sum);
        }
    
        cout << st.size() << endl;
        int cnt = 0;
    
        for(auto it=st.begin();it!=st.end();it++){
            cout << *it;
            cnt++;
            if(cnt!=st.size())cout << " ";
        }
    
        return 0;
    }

    这题白给

    最后一行无空格可以这样写

    if(it != s.begin()) printf(" ");
     
  • 相关阅读:
    HiveServer2的配置使用
    hBase-thrift 实践(java)
    Building Apache Thrift on CentOS 6.5
    linux安装thrift
    Apache Thrift with Java Quickstart(thrift入门及Java实例)
    [转载]/etc/security/limits.conf解释及应用
    storm 入门原理介绍
    Storm的wordCounter计数器详解
    CentOS6.5 安装python
    HBase 协处理器统计行数
  • 原文地址:https://www.cnblogs.com/cunyusup/p/10791296.html
Copyright © 2020-2023  润新知