• <poj 1056>IMMEDIATE DECODABILITY


    IMMEDIATE DECODABILITY
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 8811   Accepted: 4177

    Description

    An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

    Examples: Assume an alphabet that has symbols {A, B, C, D} 

    The following code is immediately decodable: 
    A:01 B:10 C:0010 D:0000 

    but this one is not: 
    A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

    Input

    Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

    Output

    For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

    Sample Input

    01
    10
    0010
    0000
    9
    01
    10
    010
    0000
    9
    

    Sample Output

    Set 1 is immediately decodable
    Set 2 is not immediately decodable
     
    

    Source


    这题运用string类可以很轻松的解决。
    程序中注意两点:sort(i,j),是将下标范围为[i,j)的元素排序。求子串string::substr(i,j)中,i是所求子串的起始点,j是所求子串的长度。
    AC Code:
    #include <iostream>
    #include <algorithm>
    #include <string>
    using namespace std;
    int main()
    {
        string str[8],s;
        int set=1,i=-1;
        bool flag;
        while(cin>>s)
        {
            if(s!="9")
            {
                i++;
                str[i]=s;
            }
            else
            {
                flag=true;
                sort(str,str+i+1);//排序
                for(int j=0;j<=i-1 && flag;j++)
                {
                    for(int k=j+1;k<=i && flag;k++)
                    {
                        if(str[j]==str[k].substr(0,str[j].length()))
                        {
                            cout<<"Set "<<set<<" is not immediately decodable"<<endl;
                            flag=false;
                        }
                    }
                }
                if(flag) cout<<"Set "<<set<<" is immediately decodable"<<endl;
                set++;
                i=-1;
            }
        }
        return 0;
    }
    


  • 相关阅读:
    练习:给Keras ResNet50源码加上正则化参数, 修改激活函数为Elu
    凸集,凸函数,凸优化问题。
    Keras用动态数据生成器(DataGenerator)和fitgenerator动态训练模型
    Lagrangian 对偶 和 Slater 条件
    凸集分离定理
    Python 中的 sorted 和 sort的区别
    工作反思
    jemalloc
    libcoap
    dropbear
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910592.html
Copyright © 2020-2023  润新知