• HDUOJ 1303


    Doubles

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1993    Accepted Submission(s): 1380


    Problem Description
    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list 
    1 4 3 2 9 7 18 22

    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9. 
     

    Input
    The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
     

    Output
    The output will consist of one line per input list, containing a count of the items that are double some other item.
     

    Sample Input
    1 4 3 2 9 7 18 22 0 2 4 8 10 0 7 5 11 13 1 3 0 -1
     

    Sample Output
    3 2 0
     

    Source
     


    #include <iostream>
    using namespace std;
    int main()
    {
    	int a[16],n,c,i,j,k;
    	while(scanf("%d",&n))
    	{
    		if(n==-1) break;
    		a[0]=n;c=0;
    		for(i=1;a[i-1]!=0;i++)
    		{
    			scanf("%d",&a[i]);
    		}
    		j=i-1;
    		for(i=0;i<j;i++)
    		{
    			for(k=i;k<j;k++)
    			{
    				if(a[i]==a[k]*2||2*a[i]==a[k])
    					c++;
    			}
    		}
    		printf("%d\n",c);
    	}
    	return 0;
    }


  • 相关阅读:
    页面调用百度地图但是使用了https证书之后不显示
    JAVA查询类别(菜单)下的所有子类别(递归)
    summernote富文本的简单使用
    thymeleaf标签在js中调用转义变量与不转义变量写法
    SpringBoot使用@Async实现异步调用
    JAVA使用多线程进行数据处理
    MapReduce-TextInputFormat 切片机制
    BootstrapTable 导出数据
    BootstrapTable 加载数据
    CDN 常用静态资源公共库
  • 原文地址:https://www.cnblogs.com/cszlg/p/2910542.html
Copyright © 2020-2023  润新知