• POJ 1949 Chores


    Farmer John's family pitches in with the chores during milking, doing all the chores as quickly as possible. At FJ's house, some chores cannot be started until others have been completed, e.g., it is impossible to wash the cows until they are in the stalls. 

    Farmer John has a list of N (3 <= N <= 10,000) chores that must be completed. Each chore requires an integer time (1 <= length of time <= 100) to complete and there may be other chores that must be completed before this chore is started. We will call these prerequisite chores. At least one chore has no prerequisite: the very first one, number 1. Farmer John's list of chores is nicely ordered, and chore K (K > 1) can have only chores 1,.K-1 as prerequisites. Write a program that reads a list of chores from 1 to N with associated times and all perquisite chores. Now calculate the shortest time it will take to complete all N chores. Of course, chores that do not depend on each other can be performed simultaneously.

    Input

    * Line 1: One integer, N 

    * Lines 2..N+1: N lines, each with several space-separated integers. Line 2 contains chore 1; line 3 contains chore 2, and so on. Each line contains the length of time to complete the chore, the number of the prerequisites, Pi, (0 <= Pi <= 100), and the Pi prerequisites (range 1..N, of course). 

    Output

    A single line with an integer which is the least amount of time required to perform all the chores. 

    Sample Input

    7
    5 0
    1 1 1
    3 1 2
    6 1 1
    1 2 2 4
    8 2 2 4
    4 3 3 5 6
    

    Sample Output

    23
    

    Hint

    [Here is one task schedule:
    
    Chore 1 starts at time 0, ends at time 5.
    Chore 2 starts at time 5, ends at time 6.
    Chore 3 starts at time 6, ends at time 9.
    Chore 4 starts at time 5, ends at time 11.
    Chore 5 starts at time 11, ends at time 12.
    Chore 6 starts at time 11, ends at time 19.
    Chore 7 starts at time 19, ends at time 23.
    ]
    题解:树形DP入门题。从根节点往下依次更新出每一个节点的最短时间,则该最短时间的最大值即为:完成家务的最短时间。
    参考代码为:
    #include <iostream>
    #include <cstring>
    using namespace std;
    const int maxn=10005;
    int c[maxn],n[maxn],dp[maxn];
     
    int main()
    {
    	ios::sync_with_stdio(false);
    	cin.tie(0);
       	int N,temp,sum=-maxn; 
       	memset(dp,0,sizeof dp);
       	cin>>N;
       	for(int i=1;i<=N;i++)
       {
        	cin>>c[i]>>n[i];  
        	if(i==1) dp[i]=c[i];
        	else
    		{
           	 	int max=-maxn;
            	if(n[i]==0) dp[i]=c[i];
            	else
    			{
                	for(int j=0;j<n[i];j++)
    				{
                    	cin>>temp;
                    	if(dp[temp]>max) max=dp[temp];
                	}
                	dp[i]=max+c[i];
            	}
        	}
          	if(dp[i]>sum) sum=dp[i];
       	}   
       	cout<<sum<<endl;
        return 0;
    }
    
    /*
    7
    5 0
    1 1 1
    3 1 2
    6 1 1
    1 2 2 4
    8 2 2 4
    4 3 3 5 6
    */
    

      

  • 相关阅读:
    编写EasyCluster V2.0 Portal主界面时的HTML心得(NOWRAP)
    Learning Perl 4ed Reading Notes Chapter4 Subroutines
    Ajax的异步,是鸡肋还是鸡排?
    JavaScript中使用eval函数将一个String当成一句JS代码来执行
    AJAX中消除Tomcat会cache action返回值的问题
    Learning Perl 4ed Reading Notes Chapter2 Scalar Data
    你知道这个语法吗?
    33中JS效果整理
    SQL语法大全[转]
    JS表单判断函数代码大全
  • 原文地址:https://www.cnblogs.com/csushl/p/9409663.html
Copyright © 2020-2023  润新知