• hdu-1198


    Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows. 


    Figure 1


    Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map 

    ADC 
    FJK 
    IHE 

    then the water pipes are distributed like 


    Figure 2


    Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn. 

    Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him? 

    Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show. 
    InputThere are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50. 
    OutputFor each test case, output in one line the least number of wellsprings needed. 
    Sample Input
    2 2
    DK
    HF
    
    3 3
    ADC
    FJK
    IHE
    
    -1 -1
    Sample Output
    2
    3

    题解:

    给你11个田地,随机给你几个,让你计算最少多少块;

    首先对11块打表,然后乐意用DFS或BFS,或并查集(下面为并查集方法),遍历每块的左和上,最后剩下多少块即为最少快数;

    AC代码为:

    #include<iostream>
    #include<cstdio>
    #include<string>
    #include<cstring>
    using namespace std;
    int type[11][4]={1,1,0,0,
        0,1,1,0,
        1,0,0,1,
        0,0,1,1,
        0,1,0,1,
        1,0,1,0,
        1,1,1,0,
        1,1,0,1,
        1,0,1,1,
        0,1,1,1,
        1,1,1,1     
    };


    string str[51];
    int n,m,fa[3300];
     
    void Init(int n)
    {
    for(int i=0;i<n;i++)
    fa[i]=i;
    }


    int Find(int a)
    {
    return a==fa[a]? a:Find(fa[a]);
    }


    void Union(int a,int b)
    {
    int fx=Find(a);
    int fy=Find(b);
    if(fx!=fy)
    fa[fx]=fy;
    }


    int main()
    {
    while(scanf("%d%d",&m,&n))
    {
    if(n<=0 || m<=0)
    break;

    Init(n*m);

    for(int i=0;i<m;i++)
    {
    cin>>str[i];
    }

    for(int i=0;i<m;i++)
    {
    for(int j=0;j<n;j++)
    {
    if(i>0&&type[str[i][j]-'A'][1]==1&&type[str[i-1][j]-'A'][3]==1)
    Union(i*n+j,(i-1)*n+j);
    if(j>0&&type[str[i][j]-'A'][0]==1&&type[str[i][j-1]-'A'][2]==1)
    Union(i*n+j,i*n+j-1);
    }
    }

    int cnt=0;
    for(int i=0;i<n*m;i++)
    {
    if(fa[i]==i)
    cnt++;
    }
    cout<<cnt<<endl;
    }

    return 0;
    }


  • 相关阅读:
    电源符号:VCC、VDD、VEE、VSS、VBAT各表示什么意思?
    Maven项目打包成war包并启动war包运行
    Jeecg-Boot 快速开发平台(前后端分离版本)
    ATX , UATX , MATX这三个板型有什么区别,ATX大板,MATX小板,UATX是什么板子。
    IO模型之NIO代码及其实践详解
    nio原理和示例代码
    jvisualvm远程监控tomcat
    jvisualvm 远程监控tomcat
    springmvc 自定义注解
    Bootstrap3基础 pagination 分页按钮 简单示例
  • 原文地址:https://www.cnblogs.com/csushl/p/9386586.html
Copyright © 2020-2023  润新知