• HDU-1698-----Just Hook


    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



    Now Pudge wants to do some operations on the hook. 

    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
    The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

    For each cupreous stick, the value is 1. 
    For each silver stick, the value is 2. 
    For each golden stick, the value is 3. 

    Pudge wants to know the total value of the hook after performing the operations. 
    You may consider the original hook is made up of cupreous sticks. 
    InputThe input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
    For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
    Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 
    OutputFor each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 
    Sample Input
    1
    10
    2
    1 5 2
    5 9 3
    Sample Output

    Case 1: The total value of the hook is 24.


    题解:

    线段树区间修改求和


    AC代码为:

    #include<iostream>
    #include<cstdio>
    #include<cstring>


    using namespace std;
    const int maxn=1e5+10;
    struct node{
    int l,r,sum,tag;
    } tree[maxn<<2];


    void build(int k,int l,int r)
    {
    tree[k].l=l,tree[k].r=r;
    tree[k].tag=0;
    if(l==r)
    {
    tree[k].sum=1;
    return ;
    }
    int mid=(l+r)>>1;
    build(k<<1,l,mid);
    build(k<<1|1,mid+1,r);
    tree[k].sum=tree[k<<1].sum+tree[k<<1|1].sum;
    }


    void pushup(int k)
    {
    tree[k].sum=tree[k<<1].sum+tree[k<<1|1].sum;
    }


    void pushdown(int k)
    {
    tree[k<<1].tag=tree[k].tag;
    tree[k<<1|1].tag=tree[k].tag;
    tree[k<<1].sum=(tree[k<<1].r-tree[k<<1].l+1)*tree[k].tag;
    tree[k<<1|1].sum=(tree[k<<1|1].r-tree[k<<1|1].l+1)*tree[k].tag;
    tree[k].tag=0;
    }


    void update(int k,int l,int r,int x)
    {
    if(tree[k].l==l&&tree[k].r==r)
    {
    tree[k].sum=x*(tree[k].r-tree[k].l+1);
    tree[k].tag=x;
    return ;
    }

    if(tree[k].tag) pushdown(k);

    int mid=(tree[k].r+tree[k].l)>>1;
    if(r<=mid) update(k<<1,l,r,x);
    else if(l>=mid+1) update(k<<1|1,l,r,x);
    else update(k<<1,l,mid,x),update(k<<1|1,mid+1,r,x);

    pushup(k);
    }


    int main()
    {
    int t,N,Q,x,y,z,cas=1;
    scanf("%d",&t);
    while(t--)
    {
    scanf("%d%d",&N,&Q);
    build(1,1,N);
    for(int i=1;i<=Q;i++)
    {
    scanf("%d%d%d",&x,&y,&z);
    update(1,x,y,z);
    }
    printf("Case %d: The total value of the hook is %d. ",cas++,tree[1].sum);
    }
    return 0;
    }

  • 相关阅读:
    利用CSS计数函数counter()实现计数
    弹跳加载动画特效Bouncing loader
    HTML页面中解决内容元素随窗口变化布局变乱问题
    CSS中列表项list样式
    框模型中设置内容区域元素占地尺寸box-sizing属性
    PHP100视频教程-->视频下载
    HTML页面中5种超酷的伪类选择器:hover效果
    HTML中获取input中单选按钮radio数据(性别例子)
    HTML中 DOM操作的Document 对象详解(收藏)
    14、输入一个链表,从尾到头打印链表每个节点的值。
  • 原文地址:https://www.cnblogs.com/csushl/p/9386570.html
Copyright © 2020-2023  润新知