• POJ2528---Mayor's posters


    The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
    • Every candidate can place exactly one poster on the wall. 
    • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
    • The wall is divided into segments and the width of each segment is one byte. 
    • Each poster must completely cover a contiguous number of wall segments.

    They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
    Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 
    Input
    The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.
    Output
    For each input data set print the number of visible posters after all the posters are placed. 

    The picture below illustrates the case of the sample input. 
    Sample Input
    1
    5
    1 4
    2 6
    8 10
    3 4
    7 10
    
    Sample Output
    4


    题解:这题注意数据范围,需要离散化(就是将大区间映射为小区间而其表示的内容不变),用线段树区间修改

    AC代码为:


    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    using namespace std;


    const int maxn=20000+100;
    int tree[maxn<<4];
    int li[maxn],ri[maxn];
    int lisan[3*maxn];
    bool visit[3*maxn];


    void pushdown(int p)
    {
        tree[p<<1]=tree[(p<<1)|1]=tree[p];
        tree[p]=-1;
    }


    void update(int p,int l,int r,int x,int y,int v)
    {
        if(x<=l&&y>=r)
        {
            tree[p]=v;
            return;
        }
        if(tree[p]!=-1) pushdown(p);
        int mid=(l+r)>>1;
        if(y<=mid) update(p<<1,l,mid,x,y,v);
        else if(x>mid) update((p<<1)|1,mid+1,r,x,y,v);
        else update(p<<1,l,mid,x,mid,v),update((p<<1)|1,mid+1,r,mid+1,y,v);
    }


    int ans;


    void query(int p,int l,int r)
    {
        if(tree[p]!=-1)
        {
            if(!visit[tree[p]])
            {
                ans++;
                visit[tree[p]]=true;
            }
            return;
        }
        if(l==r) return;
        int mid=(l+r)>>1;
        query(p<<1,l,mid);
        query((p<<1)|1,mid+1,r);
    }


    int main()
    {
        int T;
        scanf("%d",&T);
        int n;
        
        while(T--)
        {
            scanf("%d",&n);
            memset(tree,-1,sizeof(tree));
            memset(visit,false,sizeof(visit));
            int tot=0;
            
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&li[i],&ri[i]);
                lisan[tot++]=li[i];
                lisan[tot++]=ri[i];
            }
            
            sort(lisan,lisan+tot);
            int m=unique(lisan,lisan+tot)-lisan;
            int t=m;
            
            for(int i=1;i<t;i++)
            {
                if(lisan[i]-lisan[i-1]>1)
                    lisan[m++]=lisan[i-1]+1;
            }
            
            sort(lisan,lisan+m);
            
            for(int i=0;i<n;i++)
            {
                int x=lower_bound(lisan,lisan+m,li[i])-lisan;
                int y=lower_bound(lisan,lisan+m,ri[i])-lisan;
                update(1,0,m-1,x,y,i);
            }
            
            ans=0;
            query(1,0,m-1);
            
            printf("%d ",ans);
        }
        return 0;
    }
    /*  1
    5
    1 4
    2 6
    8 10
    3 4
    7 10
    */










  • 相关阅读:
    Navicat cannot create file xxx.sql.bak
    异步分片计算在腾讯文档的实践
    一次磁盘占用率 100% 的排查经历!
    程序员必知的“大数据”基础知识!
    用树莓派构建一台服务器,永久运行网站
    elasticsearch 百亿级数据检索案例与原理
    Redis 持久化策略浅析
    一文聊透微服务接口设计原则
    MySQL架构总览>查询执行流程>SQL解析顺序
    用 Python 破解 WiFi 密码,太刺激了
  • 原文地址:https://www.cnblogs.com/csushl/p/9386569.html
Copyright © 2020-2023  润新知