• CSU-2018


    The gaming company Sandstorm is developing an online two player game. You have been asked to implement the ranking system. All players have a rank determining their playing strength which gets updated after every game played. There are 25 regular ranks, and an extra rank, “Legend”, above that. The ranks are numbered in decreas- ing order, 25 being the lowest rank, 1 the second highest rank, and Legend the highest rank.

    Each rank has a certain number of “stars” that one needs to gain before advancing to the next rank. If a player wins a game, she gains a star. If before the game the player was on rank 6-25, and this was the third or more consecutive win, she gains an additional bonus star for that win. When she has all the stars for her rank (see list below) and gains another star, she will instead gain one rank and have one star on the new rank.

    For instance, if before a winning game the player had all the stars on her current rank, she will after the game have gained one rank and have 1 or 2 stars (depending on whether she got a bonus star) on the new rank. If on the other hand she had all stars except one on a rank, and won a game that also gave her a bonus star, she would gain one rank and have 1 star on the new rank. If a player on rank 1-20 loses a game, she loses a star. If a player has zero stars on a rank and loses a star, she will lose a rank and have all stars minus one on the rank below. However, one can never drop below rank 20 (losing a game at rank 20 with no stars will have no effect).

    If a player reaches the Legend rank, she will stay legend no matter how many losses she incurs afterwards. The number of stars on each rank are as follows:

    • Rank 25-21: 2 stars

    • Rank 20-16: 3 stars

    • Rank 15-11: 4 stars

    • Rank 10-1: 5 stars

    A player starts at rank 25 with no stars. Given the match history of a player, what is her rank at the end of the sequence of matches?

    Input

    There will be several test cases. Each case consists of a single line describing the sequence of matches. Each character corre- sponds to one game; ‘W’ represents a win and ‘L’ a loss. The length of the line is between 1 and 10 000 characters (inclusive).

    Output

    Output a single line containing a rank after having played the given sequence of games; either an integer between 1 and 25 or “Legend”.

    Sample Input

    WW
    WWW
    WWWW
    WLWLWLWL
    WWWWWWWWWLLWW
    WWWWWWWWWLWWL

    Sample Output

    25
    24
    23
    24
    19
    18

    Hint

    #include<iostream>
    #include<cmath>
    #include<cstdio> 
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int main ()
    {
    	char s[11000];
    	while(~scanf("%s",s))
    	{
    		int len = strlen(s);
        	int star = 0;
        	int win = 0;
    
        	int rank = 25;
        	for (int i = 0; i < len; i++)
    		{
        	    if (rank == 0) 
    			{
           	     	break;  
           	 	}
           		 if (s[i] == 'W')
    			{
            	    win ++;
             	   star++;
    
            	    if (win >= 3 && rank > 5) 
    					star++; 
                
                	if (rank<=25 && rank>=21 && star > 2) 
    				{
                   		 rank--;
                	    star-=2;
                	}
                	if (rank>=16 && rank<=20 && star > 3)
    				{
                	    rank--;
                	    star-=3;
                	}
                	if (rank>=11 && rank<=15 && star > 4)
    				{
                	    rank--;
                	    star-=4;
                	}
                	if (rank>=1 && rank<=10 && star > 5)
    				{
                	    rank--;
                	    star-=5;
                	}
            	}
            	else 
    			{
                	win = 0;
                	if (rank>=21)  
    					continue;
                	star --;  
                	if (star < 0)
    				{
                 	    if (rank == 20) 
    					{
                    	    star = 0;
                    	}
                    	if (rank>=15 && rank<=19)
    					{
                    	    rank++;
                    	    star = 2;
                    	}
                    	if (rank>=10 && rank<15)
    					{
                    	    rank++;
                    	    star = 3;
                    	}
    
                    	if (rank>=1 && rank<=9)
    					{
                    	    rank++;
                    	    star = 4;
                    	}
                    }
                }
            }
        
        	if (!rank)  
    			cout<<"Legend"<<endl;
        	else 
    			cout<<rank<<endl;
    	}
        
        
    		
        return 0;
    
    } 
  • 相关阅读:
    App测试从入门到精通之安装、卸载和运行测试
    App测试从入门到精通之App分类和场景操作系统
    一步到位带你入门Selenium
    MAMP和WAMP搭建Web环境,数据库,数据分布可视化
    爬虫 Http请求,urllib2获取数据,第三方库requests获取数据,BeautifulSoup处理数据,使用Chrome浏览器开发者工具显示检查网页源代码,json模块的dumps,loads,dump,load方法介绍
    Python 基本语法,文件读写,数据结构和类型
    python 数据工程 and 开发工具Sublime
    jieba user guide
    python各类项目模块记录
    python parse xml using DOM
  • 原文地址:https://www.cnblogs.com/csushl/p/9386508.html
Copyright © 2020-2023  润新知