汉字统计
Problem Description
统计给定文本文件中汉字的个数。
Input
输入文件首先包含一个整数n,表示测试实例的个数,然后是n段文本。
Output
对于每一段文本,输出其中的汉字的个数,每个测试实例的输出占一行。
[Hint:]从汉字机内码的特点考虑~
[Hint:]从汉字机内码的特点考虑~
Sample Input
2 WaHaHa! WaHaHa! 今年过节不说话要说只说普通话WaHaHa! WaHaHa! 马上就要期末考试了Are you ready?
Sample Output
14 9
AC code:
#include<stdio.h>
#include<math.h>
#include<ctype.h>
#include<string.h>
#include<stdlib.h>
#define N 10000
int main()
{
int n;
char s[N];
scanf("%d%*c",&n);
while(n--)
{
int i,len,count=0;
gets(s);
len=strlen(s);
for(i=0; i<len; i++)
{
if(s[i]<' ')
{
count++;
}
}
printf("%d\n",count/2);
memset(s,0,sizeof(s));
}
#include<math.h>
#include<ctype.h>
#include<string.h>
#include<stdlib.h>
#define N 10000
int main()
{
int n;
char s[N];
scanf("%d%*c",&n);
while(n--)
{
int i,len,count=0;
gets(s);
len=strlen(s);
for(i=0; i<len; i++)
{
if(s[i]<' ')
{
count++;
}
}
printf("%d\n",count/2);
memset(s,0,sizeof(s));
}
}