• C_Dp


    <span style="color:#000099;">/*
    C - 简单dp 例题
    Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    Input
    The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
    Output
    For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
    Sample Input
    abcfbc         abfcab
    programming    contest 
    abcd           mnp
    Sample Output
    4
    2
    0
    By Grant Yuan
    2014.7.16
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    using namespace std;
    char a[1000];
    char b[1000];
    int dp[1000][1000];
    int max(int aa,int bb)
    {
        return aa>=bb?aa:bb;
    }
    int main()
    {   int l1,l2;
        while(~scanf("%s%s",a,b)){
            l1=strlen(a);
            l2=strlen(b);
            memset(dp,0,sizeof(dp));
            for(int i=0;i<l1;i++)
              for(int j=0;j<l2;j++)
                {
                    if(a[i]==b[j])
                      dp[i+1][j+1]=dp[i][j]+1;
                    else
                      dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
                }
            cout<<dp[l1][l2]<<endl;
          }
          return 0;
    }
    </span>


  • 相关阅读:
    COMPUTE BY 子句 cube 子句
    性能计数器 可接受值 或者说参考范围
    我们也来hold住优化SQL SERVER锁的使用
    反编译工具源代码
    图片居中,图片垂直居中,图片水平居中
    SessionStateTempDataProvider类需要启用会话状态(2)
    是我Out了,还是IT市场真井喷了?
    四天玩转 Windows Phone 开发
    从物理结构说sql server 优化
    SEO和百度
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254509.html
Copyright © 2020-2023  润新知