• H_Dp


    <span style="color:#000099;">/*
    H - 简单dp 例题扩展
    Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 
    
    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 
    Input
    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
    Output
    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
    Sample Input
    5
    Ab3bd
    Sample Output
    2
    By Grant Yuan
    2014.7.16
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    using namespace std;
    char a[5002];
    char b[5003];
    int dp[2][5003];
    int n;
    int max(int aa,int bb){
      return aa>=bb?aa:bb;
    }
    
    int main()
    {
       while(~scanf("%d",&n)){
         scanf(" %s",&a);
         for(int i=0;i<n;i++)
           b[n-1-i]=a[i];
          
        // puts(a);
        // puts(b);
         memset(dp,0,sizeof(dp));
         int flag=0,flag1=0;
         for(int i=0;i<n;i++)
           for(int j=0;j<n;j++)
           {
               if(a[i]==b[j])/*{flag1=0;
                 if(flag==0)
                    dp[1][j+1]=dp[0][j]+1,flag=1;
                  else
                     dp[0][j+1]=dp[1][j]+1,flag=0;
                     }*/
                     dp[(i+1)&1][j+1]=dp[i&1][j]+1;
                else
                  {/*flag1=1;
                      if(flag==0)
                        dp[1][j+1]=max(dp[0][j+1],dp[1][j]),flag=1;
                      else
                        dp[0][j+1]=max(dp[1][j+1],dp[0][j]),flag=0;*/
                        dp[(i+1)&1][j+1]=max(dp[(i+1)&1][j],dp[i&1][j+1]);
                  }
                  //if(flag1==0)cout<<"相等";
                  //else cout<<"不相等";
                 // cout<<"flag: "<<"i: "<<flag<<" "<<i<<" "<<j<<" "<<dp[flag][j+1]<<endl;
                //  system("pause");
           }
           int l;
           /*if(flag==1)
             l=dp[1][n];
            else
             l=dp[0][n];*/
             l=dp[n&1][n];
           cout<<n-l<<endl;}
           return 0;
    }
    </span>

  • 相关阅读:
    falling object思路总结
    Real-Time Compressive Tracking 论文笔记
    xgboost python windows编译问题
    云服务三大部署模式-私有云、公有云、混合云谁才是云计算未来的主流
    NS3网络仿真(12): ICMPv4协议
    Android隐藏输入法键盘(hideSoftInputFromInputMethod没有效果)
    leetcode-Gas Station
    BEGINNING SHAREPOINT&#174; 2013 DEVELOPMENT 第10章节--SP2013中OAuth概览 总结
    hdu4737A Bit Fun 线段树
    EA生成实体类代码
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254505.html
Copyright © 2020-2023  润新知