• 优先队列


    <span style="color:#000099;">/*
    &&copyright
         notice():
    
    ***algoithm: queue
    ***auther:   Grant Yuan
    ***time:     2014.7.18
    ***source:   contest
    *
    
    A - Fence Repair
    Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
    
    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
    
    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
    
    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
    
    Input
    Line 1: One integer N, the number of planks 
    Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
    Output
    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
    Sample Input
    3
    8
    5
    8
    Sample Output
    34
    Hint
    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
    */
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cstdlib>
    #include<algorithm>
    #include<queue>
    using namespace std;
    int n,m;
    long long s1,s2,sum=0;
    priority_queue<long long,vector<long long>,greater<long long> > q;
    int main()
    {   long long t;
        while(~scanf("%d",&n)){
            sum=0;
        while(!q.empty()) q.pop();
          for(int i=0;i<n;i++){
            cin>>t;
            q.push(t);}
            while(q.size()>1)
              {
                  s1=q.top();q.pop();
                  s2=q.top();q.pop();
                  q.push(s1+s2);
                  sum+=s1+s2;
              }
            cout<<sum<<endl;}
            return 0;
    }
    </span>

  • 相关阅读:
    MediaInfo代码阅读
    HEVC与VP9之间的对比
    x264阅读记录-3
    x264阅读记录-2
    x264阅读记录-1
    Linux脚本程序
    VS2015 ASP.NET5 Web项目结构浅析
    VS2015 Apache Cordova第一个Android和IOS应用
    VS2015 C#6.0 中的那些新特性
    aehyok.com的成长之路三——框架结构
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254504.html
Copyright © 2020-2023  润新知