• 01背包


    <span style="color:#3333ff;">/*
    __________________________________________________________________________________________________
    *     copyright:   Grant Yuan                                                                     *
    *     algorithm:   01背包                                                                       *
    *     time     :   2014.7.18                                                                      *
    *_________________________________________________________________________________________________*
    F - 01背包
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
    The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 
    
    
     
    Input
    The first line contain a integer T , the number of cases. 
    Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
     
    Output
    One integer per line representing the maximum of the total value (this number will be less than 2 31).
     
    Sample Input
     1
    5 10
    1 2 3 4 5
    5 4 3 2 1 
     
    Sample Output
     14 
     */
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<functional>
    #include<queue>
    #include<stack>
    #include<cstdlib>
    using namespace std;
    
    int v[1001];
    int p[1001];
    int n,sv,t;
    int dp[2][1001];
    
    int main()
    {
    	cin>>t;
    	while(t--){
    	  cin>>n>>sv;
    	  for(int i=0;i<n;i++)
    		  cin>>p[i];
    	  for(int i=0;i<n;i++)
    		  cin>>v[i];
    	  memset(dp,0,sizeof(dp));
    	  for(int i=0;i<n;i++)
    		 for(int j=0;j<=sv;j++)
    	  {
    	  	if(j<v[i])
    			  dp[(i+1)&1][j]=dp[i&1][j];
    	    else
    			  dp[(i+1)&1][j]=max(dp[i&1][j],dp[i&1][j-v[i]]+p[i]);
    
    	  }
    	  cout<<dp[n&1][sv]<<endl;
    	}
    	return 0;
    }
    </span>

  • 相关阅读:
    python模块导入
    linux总结shell
    linux和shell关系
    gdb调试工具
    C语言.c和.h
    CSS cursor 属性
    html dom SetInterVal()
    css hover伪类选择器与JQuery hover()方法
    CSS 清除浮动 clear 属性
    block,inline和inline-block概念和区别
  • 原文地址:https://www.cnblogs.com/codeyuan/p/4254502.html
Copyright © 2020-2023  润新知